Problems with AF on new DA*300 F4.


walt

Link Posted 14/04/2017 - 17:45
Hi I had a quick exchange of forum messages with some users yesterday in link and it made me think about some issues I've been having with my new (Dec 16) DA*300 F4 and my older K3. I'm struggling matching the consistency of AF I always got with my FA*300 F4.5 which I've had new since the mid 90's and used on many digital bodies, K100D, GX10, K-r, K30 and K3 without issues. I thought I'd drop my thoughts here and see if anyone has ideas or experience of the problem.
I tested the DA* on my K3 and K30 today and noticed that in AF-S, centre point AF, that every now and then the lens would not confirm focus on static shot, Without moving the af away from the area where it failed after release and re-press of the shutter release it would then confirm focus. Sometimes it would fail a few times in a row and then af fine for the next few. These were not difficult subjects to focus on just objects at random around the garden. Also it did not react like I expect when it can't confirm af by racking to close then infinity and then flashing the af confirmation light in the viewfinder. It just stayed at the last point it was focused on and just flashed the af confirmation light. It did this on both the K3 and the K30. So I then swapped to the FA*300 and this never happened, it locked focus every time. So I swapped back to the DA* and it had the same problem, I did this a few times with exact results.
Now I've never been happy with the AF on this DA* lens since I got it, it can be slow at times to confirm af even on the the subject it has already just focused on and it's AF-C is just poor in comparison to the FA*. I take mainly wildlife and I've been so concerned with it that I upgraded my Canon 50D to a 7D and took that on a recent trip to try and get some first in my life images of white-tailed Eagles and have been seriously thinking of moving away from pentax because of these issues. But the chat yesterday and the testing today is making me think I have a duff DA* (perhaps the dreaded SDM issues that stopped me buying this lens for so many years?).
Anyway ask away if you need clarification on some points because although it's all clear in my mind I may not have explained it as good as I could have.
Also, this is my first experience of SDM lenses, all my others are screw driven so I have no baseline to judge the sdm performance of this DA*.
Thanks
Walt
My newer photos google photos
My older Flickr photos Flickr
Even older ones Picasa
Last Edited by walt on 14/04/2017 - 18:11

wvbarnes

Link Posted 14/04/2017 - 21:05
Hi Walt,

I and a friend have used the 300 F4 DA* (mine second hand early model) on K3 cameras with and without tele adapter without problem for a couple of years on a wide range of subjects.

Example with tele adapter... https://www.pentaxuser.com/photo/user-10782/no--this-way-86554

You seem to have a faulty lens. hopefully the two year warranty is still in force.

i've personally moved to the, very fast for AF, 55 - 300 PLM powered lens for my travel use which I find easier but of course it is a slower aperture at 300.
Last Edited by wvbarnes on 14/04/2017 - 21:32

walt

Link Posted 15/04/2017 - 11:15
Thanks for the feedback Bill, yep still under warranty.
Walt
My newer photos google photos
My older Flickr photos Flickr
Even older ones Picasa
Add a Comment
You must be registered or logged-in to comment.