using a tele converter


marmimag

Link Posted 02/10/2014 - 14:52
I have a K3 and use a Sigma 70-200 lens and have purchased a Sigma APO tele converter 2 x DG AF but when I attach it to the camera and then attach the lens when I turn the camera on the Auto focus just flashes on the Info screen and ~I can't change anything on the menu? should I be adjusting something on my camera before I use it?
Any suggestions or has anyone else had this problem?

Maggi
Marmimag

carmagw

Link Posted 02/10/2014 - 15:00
If the 70-200 is an HSM lens then the Sigma TC (pentax fit) will not work with it. It only works with some screw drive leneses. sigma has a list of compatible lens on their website somewhere.

Regards

George
Last Edited by carmagw on 02/10/2014 - 15:03

Helpful

marmimag

Link Posted 02/10/2014 - 15:07
Thanks for this

Marmimag

bforbes

Link Posted 02/10/2014 - 15:36
Here is the compatibility chart link
Barrie
Too Old To Die Young
.
Pentax K1 K5-IIS K-01 K20D A50/2 A50/1.7 DA10-17 DA18-250 DA18-135 DA18-55 DA300 DA40 DA50-135 DA50-200 DA55-300 DA70 F35-70 DFA150-450 FA20-35 FA100 FA135 FA35 FA28 FA43 FA50 FA77 K55/1.8 M135/3.5 M200/4 M28/3.5 M28/2.8 M40/2.8 Q 01 02 MX-1 I-10 Sigma 15 24 105 180 8-16 10-20 17-35 17-50/2.8 24-70 400/5.6MF Tamron 70-200/2.8 17/3.5MF 24/2.5MF 28/2.5MF 90/2.5MF


http://www.pentaxphotogallery.com/artists/barrieforbes

Helpful

jeallen01

Link Posted 02/10/2014 - 18:27
Get one of "pz" t/cs as they do support HSM - works with my 150-500 HSM OS Sigma
K-3 II, K-3 and K-30 (now running the Hacked K-50 f/w, so it thinks it is one of those ), & some Sigma and Pentax lenses (and a lot of old 35mm gear!) - and now a K-70 from SRS

Helpful

percy

Link Posted 02/10/2014 - 19:00
The Tamron-F 1.4X Pz-AF MC4 works well with the Sigma 70-200 HSM (provided you have reasonably good light) if you can find one. Doesn't give as much range as a 2x converter, but does let in more light and doesn't affect image quality to the same degree.
http://www.pentaxforums.com/userreviews/a-tamron-f-1-4x-pz-af-mc4.html
Last Edited by percy on 02/10/2014 - 19:01

jeallen01

Link Posted 02/10/2014 - 19:04
Mine's a Kenko version - almost the same, and it worked with the 150-500 on the K-3 in the bedroom under not-very-good artificial light (but not tried it for real outside)!
K-3 II, K-3 and K-30 (now running the Hacked K-50 f/w, so it thinks it is one of those ), & some Sigma and Pentax lenses (and a lot of old 35mm gear!) - and now a K-70 from SRS

Helpful

marmimag

Link Posted 02/10/2014 - 20:57
thanks guys for all your help and comments!
Maggi
Marmimag
Add a Comment
You must be registered or logged-in to comment.