Strange lens effects


Mike-P

Link Posted 17/08/2017 - 22:18
Have a read of this
. My Flickr

jeallen01

Link Posted 17/08/2017 - 22:32
Michael
Based on your last post, it appears to be the lens that is the issue as I had a similar one with my 100-300 F4 on 3 different bodies a couple of years ago. I took it (literally, I live not too far away!) to Sigma Imaging UK in Welwyn, and they then diagnosed the problem as being the lens AF module - which, very luckily, they were able to correct very cheaply with a new module (likely to have been virtually the last one for that lens !) from Japan.
Not sure if your problem is the same, but I would contact Sigma as the first step because they are absolutely first rate and don't rip you off! (I had previously sent them my 150-500 HSM OS because it seemed to very slow to focus. They could not find anything wrong with it - because that is how that that lens works , and posted it back without charging me ANYTHING, even after I offered to pay the return postage as I thought that that would only be "fair")
OTOH, Johnsons Photophia who then fixed the K-3 which also had some focusing issues are entirely another matter (NOT good - left and right hand situation), and it cost a lot more (even with the Pentax User discount) than I was charged by Sigma for fixing the 100-300 F4!
K-3 II, K-3 and a K-70 from SRS (having now relegated the K-30 /"K-50" to a backup body), & some Sigma and Pentax lenses (and a lot of old 35mm gear!)
Last Edited by jeallen01 on 17/08/2017 - 22:33

michaelblue

Link Posted 18/08/2017 - 08:29
Mike-P wrote:
Have a read of this

Thanks Mike, very interesting. Maybe I'm expecting too much from this lens although his photos still look better than some of mine.
Regards,
Michael
My new website:link

Mike-P

Link Posted 18/08/2017 - 17:23
Well if it's still in warranty and your not happy then send it to Sigma, it can't hurt. You may have a duff one or it maybe ok but at least it will put your mind at rest one way or the other.
. My Flickr
Last Edited by Mike-P on 18/08/2017 - 17:24

jeallen01

Link Posted 20/08/2017 - 21:13
In the AP I received yesterday, there is a letter from someone who sent a 7-8 yr old Sigma 70-200 f2.8 HSM to Sigma Imaging UK for repair, but when, having sent it back to Japan Sigma Imaging UK were told that the parts were no longer available, they sent him a brand new 70-200 f2.8 HSM OS for just the standard price list cost of a repair.

THAT IS SERVICE, BIG TIME! - no wonder then that I use mainly Sigma lenses! .

PS: Ricoh, and Johnsons Photophia - TAKE NOTE!
K-3 II, K-3 and a K-70 from SRS (having now relegated the K-30 /"K-50" to a backup body), & some Sigma and Pentax lenses (and a lot of old 35mm gear!)
Last Edited by jeallen01 on 20/08/2017 - 21:14

Algernon

Link Posted 21/08/2017 - 08:26
Rico Johnson-Photophia I went to school with him

--
Half Man... Half Pentax ... Half Cucumber

Pentax K-1 + K-5 and some other stuff

Algi

jeallen01

Link Posted 21/08/2017 - 08:53
Algernon wrote:
Rico Johnson-Photophia I went to school with him

--

So, you are the one we have to blame for all the trouble we have with him/them
K-3 II, K-3 and a K-70 from SRS (having now relegated the K-30 /"K-50" to a backup body), & some Sigma and Pentax lenses (and a lot of old 35mm gear!)
Add a Comment
You must be registered or logged-in to comment.