Sigma 150 - 500 help needed.


scarr1

Link Posted 29/10/2016 - 18:30
Hi all.
I have a sigma dg 150 - 500mm f5-6.3 apo hsm, which wont auto focus properly.
It has been fine up till this week (i dont use it very often though), but all of a sudden it seems to be really hunting for focus, then when it stops hunting, subject is not in focus....nowhere near!
I use it on a k3, and it does it on both k3 bodies i have, so doubt its the camera, and all my other lenses are fine. Batteries were fully charged.
Anyone else had this?
Any advice?

Thanks,
Simon.

Chrism8

Link Posted 29/10/2016 - 19:07
I've just had the mount changed on mine by Sigma to suit the K1 and they did a firmware update at the same time, may be time for a service particularly as you say you don't use it that often.
Chris

www.chrismillsphotography.co.uk

" A Hangover is something that occupies the Head you neglected to use the night before".

-------------------------------------------------------------
K1 - Sigma 85mm F1.4, Pentax 150 -450 F4.5 / 5.6, Pentax FA 24 - 70 F2.8

Sigma 100-300 F4, Samyang 14mm F2.8, Sigma 70-200 F2.8,

K5iis - Sigma 17 - 70 F2.8, Sigma 70 - 300 F3.5/F5.6, Sigma 18 - 200 F3.6 / F4.5.

dpm

Link Posted 29/10/2016 - 23:30
only time I've ever seen the 150-500 do odd things it's always been the battery *not* being brilliant that has been the problem.

jeallen01

Link Posted 31/10/2016 - 17:17
You might want to take a look at my post on the first page of this thread about my experiences with the K-5 & K-3.

OTOH, there may be something wrong with the lens, in which case you should probably contact Sigma Imaging at Welwyn as they do a great job of servicing their lenses, are not expensive (the menu prices are shown on their website) and very honest about what they find, or do not. Couple of years ago they took a look at my 150-500 APO HSM OS because I thought it focused very slowly. Turns out "that is what it does", and they could find no fault with it and did not charge me a penny (even sending it back RMSD at no charge even though I offered to pay)!
K-3 II, K-3 and a K-70 from SRS (having now relegated the K-30 /"K-50" to a backup body), & some Sigma and Pentax lenses (and a lot of old 35mm gear!)

ilovesaabs

Link Posted 31/10/2016 - 20:25
I used to own the same lens but can't remember whether it had a focus limiter.......check that just in case...
AKA Welshwizard/PWynneJ
Assorted Pentax/Nikon/Mamiya stuff
Add a Comment
You must be registered or logged-in to comment.