K5 Dust Removal, Action.


ChrisR

Link Posted 07/01/2012 - 10:43
A K5 question please, regarding dust removal action.

I also have a K10, when this is set for dust removal on (start up action), you can hear and feel a good shake, when the camera is switched on.

However with the K5, set for dust removal on (start up action), there is just a small noise, the nearest I can describe as, almost like, a half shutter operation sound, probably less than half a second.

This same sound is there, on start up (switch on) whither the dust removal action is set to on or off.

In the K5, manual, the dust removal is described as (ultrasonic vibrations), so maybe there is nothing to hear or feel, unlike the K10, which is more of a mechanical shake. I think I may have just answered my own question.

Sorry if this has been asked before, but canít find anything in the forum, relating to this.

Take care.
Chris R.

I. El. (Eng). (Rtd).

alfpics

Link Posted 07/01/2012 - 10:47
I have the K7 which has the ultrasonic action which I can just hear as a brief very high pitch sound lasting approx half a second (maybe like a half-shutter sound?!)

Why you should get a sound with it de-activated on start-up, I don't know

Andy
Andy

daphnejohn

Link Posted 07/01/2012 - 11:03
I get the same sound with my K5 and raised it on this forum some months ago. The consensus seemed to be that the ultrasonic dust removal is silent and the sound we are hearing is something to do with image stabilisation. I also have a K10 like yourself and find the noise and vibration very reassuring!

John

snappychappy

Link Posted 07/01/2012 - 15:15
I believe that the difference is mechanical, as in vibrating the sensor in the K10. In the K5/7 it's ultrasonic, or electronic dust removal.
My piccies.

python118

Link Posted 07/01/2012 - 15:41
Hi, just wondering how many times in the year, when you have to perform this operation, i surpose really how longs a piece of string

Frogfish

Link Posted 07/01/2012 - 17:23
python118 wrote:
Hi, just wondering how many times in the year, when you have to perform this operation, i surpose really how longs a piece of string

How many times in a year !?!

I have it to perform every time I switch the camera on - then every time I reformat the SD after a full day's shooting I do it another two times .... and I still haven't gone blind
http://frogfish.smugmug.com/ Pentax. Pentax DA*300/4, Cosina 55/1.2, Lens Baby Composer Pro & Edge 80, AFA x1.7, Metz 50 af1.
Nikon. D800. D600. Sigma 500/4.5, Nikon 300/2.8 VRII, Sigma 120-300/2.8, Zeiss Distagon ZF2 21/2.8, Zeiss Distagon ZF2 35/2.0, Sigma 50/1.4, Nikkor 85/1.8, Nikon TC20EIII, Nikon TC14EII, Kenko x1.4, Sigma 2.0

apeksdiver

Link Posted 07/01/2012 - 18:26
python118 wrote:
Hi, just wondering how many times in the year, when you have to perform this operation, i surpose really how longs a piece of string

In 2 years my K-7 has never needed the sensor cleaned still no dust when I check it

Pentaxophile

Link Posted 07/01/2012 - 19:38
apeksdiver wrote:
python118 wrote:
Hi, just wondering how many times in the year, when you have to perform this operation, i surpose really how longs a piece of string

In 2 years my K-7 has never needed the sensor cleaned still no dust when I check it

Proves how effective the dust removal really is (presuming you have it turned on at startup)...
[link=https://500px.com/will_brealey/[/link]

ChrisR

Link Posted 08/01/2012 - 09:13
alfpics wrote:
I have the K7 which has the ultrasonic action which I can just hear as a brief very high pitch sound lasting approx half a second (maybe like a half-shutter sound?!)

Why you should get a sound with it de-activated on start-up, I don't know

Andy

daphnejohn wrote:
I get the same sound with my K5 and raised it on this forum some months ago. The consensus seemed to be that the ultrasonic dust removal is silent and the sound we are hearing is something to do with image stabilisation. I also have a K10 like yourself and find the noise and vibration very reassuring!

John

snappychappy wrote:
I believe that the difference is mechanical, as in vibrating the sensor in the K10. In the K5/7 it's ultrasonic, or electronic dust removal.

Many thanks Andy, John and Stephen.
Now reassured.

Take care.
Chris R.

I. El. (Eng). (Rtd).

Patty

Link Posted 13/05/2012 - 13:59
Hi there,

I am now the proud owner of a K5. Upgraded from Kx with the prices as they are now and the cashback, Just couldn't resist it. Been considering it and the probable replacement will be miles over my prices.

Just tried the self clean on sensor which on the Kx really rattles like a tin of nails but could not hear anything whatsoever Questioned to myself about a fault but remembered reading this posting. Had a good search and up it came.

All okay according to how this posting reads.

Could be worth remembering this then if you are a K5 user or considering buying one.

Lots of reading and trials to be done to learn to control this camera. It came with firmware 1.01 although photome shows this years build. I have upgraded to 1.13 so don't know what any difference would be but this seems okay.

Patty

wvbarnes

Link Posted 13/05/2012 - 15:41
I was surprised at the quiet buzz from my new K5 after my KR.

The KR sensor needed blow brush cleaning regularly and like my earlier KX keeping dist out of the Pentamirror was hard!

Also for the K5 the lack of shutter and mirror sound was what impressed me along with the huge 100% viewfinder!

I love it and can't wait to go back to Greece next week to put it fully though its paces.
Add a Comment
You must be registered or logged-in to comment.