K3 2Front e dial stopped working


ant1clock

Link Posted 07/01/2018 - 09:39
Hi

First post. I have had my K3-II for just over five months, bought from new.

Today while out shooting (outside temp -2C) The front e dial has stopped working, canít change aperture or move the tabs in the menu.

I have treated this camera very gently as it was a lot of money to me and itís never been even been out in the rain and I always equalise the temp when returning home.

Have I pressed a button combination to disable the dial or is it broke.

Cheers

Mel

Chrism8

Link Posted 07/01/2018 - 09:44
Try taking the battery out for 30 seconds and then replace
Chris

www.chrismillsphotography.co.uk

" A Hangover is something that occupies the Head you neglected to use the night before".

-------------------------------------------------------------
K1 - Pentax 100 Macro F2.8 - Sigma 85mm F1.4, Pentax 150 -450 F4.5 / 5.6

Pentax FA 24 - 70 F2.8, Sigma 100-300 F4, Samyang 14mm F2.8, Sigma 70-200 F2.8,

K5iis - Sigma 17 - 70 F2.8, Sigma 70 - 300 F3.5/F5.6, Sigma 18 - 200 F3.6 / F4.5.

ant1clock

Link Posted 07/01/2018 - 09:49
Thanks for your prompt response. Just tried that but still the same.

Chrism8

Link Posted 07/01/2018 - 09:59
Other than that, is the camera working, i.e

is it auto focussing ok ?

does it take an image and is it correctly exposed ?
Chris

www.chrismillsphotography.co.uk

" A Hangover is something that occupies the Head you neglected to use the night before".

-------------------------------------------------------------
K1 - Pentax 100 Macro F2.8 - Sigma 85mm F1.4, Pentax 150 -450 F4.5 / 5.6

Pentax FA 24 - 70 F2.8, Sigma 100-300 F4, Samyang 14mm F2.8, Sigma 70-200 F2.8,

K5iis - Sigma 17 - 70 F2.8, Sigma 70 - 300 F3.5/F5.6, Sigma 18 - 200 F3.6 / F4.5.

ant1clock

Link Posted 07/01/2018 - 10:00
Yeah everything else seems to working. I put in on auto aperture and it set the aperture as per and took photos no problems.

Chrism8

Link Posted 07/01/2018 - 10:34
Ok, try removing the lens,

Wipe the contacts on both the lens and the mount to make sure they are dry with a cloth, then put the lens back checking it clicks fully home

Check you are in the correct mode, does it work properly in say fully manual ( M ) ? can u adjust the shutter speed and aperture ?

Is there a card in the camera, or is the card door open, this has caught me out on one occasion
Chris

www.chrismillsphotography.co.uk

" A Hangover is something that occupies the Head you neglected to use the night before".

-------------------------------------------------------------
K1 - Pentax 100 Macro F2.8 - Sigma 85mm F1.4, Pentax 150 -450 F4.5 / 5.6

Pentax FA 24 - 70 F2.8, Sigma 100-300 F4, Samyang 14mm F2.8, Sigma 70-200 F2.8,

K5iis - Sigma 17 - 70 F2.8, Sigma 70 - 300 F3.5/F5.6, Sigma 18 - 200 F3.6 / F4.5.

ant1clock

Link Posted 07/01/2018 - 10:35
Just investigating my issue and after pushing the on/off lever to DOF preview, the dial started working again.

Now I donít know if that did the trick or if itís because the camera has warmed up.

Will monitor the situation. I am off to update the firmware to the latest issue. I hadnít done it because the camera was working OK.

Cheers

ant1clock

Link Posted 07/01/2018 - 10:38
Thanks for your suggestions and once the camera has fully got back up to room temp I will clean the contacts. Hopefully it was just a glitch in the Matrix and it wonít happen again.

Thanks

Mel

Chrism8

Link Posted 07/01/2018 - 10:41
Hi Mel,

No problem, pleased its either resolved itself of you've found the issue, make sure the battery is fully charged before starting the firmware update
Chris

www.chrismillsphotography.co.uk

" A Hangover is something that occupies the Head you neglected to use the night before".

-------------------------------------------------------------
K1 - Pentax 100 Macro F2.8 - Sigma 85mm F1.4, Pentax 150 -450 F4.5 / 5.6

Pentax FA 24 - 70 F2.8, Sigma 100-300 F4, Samyang 14mm F2.8, Sigma 70-200 F2.8,

K5iis - Sigma 17 - 70 F2.8, Sigma 70 - 300 F3.5/F5.6, Sigma 18 - 200 F3.6 / F4.5.

tigershoot

Link Posted 07/01/2018 - 16:48
If it's that new and it does seem a problem then get it fixed under warranty.
K3ii, K-x DA16-45, DA18-55WR, DA16-85WR, DA18-135WR, DA35 F2.4, M100mm F4 Macro, M50mm F1.7, DA55-300mm, FA50mm 1.4, AF360 Flash, AF540 Flash

davidwozhere

Link Posted 08/01/2018 - 01:54
Firmware update is quite easy but, as said, do put a fully charged battery in. You won't need the power but it's good insurance.
Both the *istDS and the K5 are incurably addicted to old glass

My page on Photocrowd - link
Add a Comment
You must be registered or logged-in to comment.