K-x battery issue


SteveF

Link Posted 10/01/2016 - 21:51
Can any of you K-x users help me please?

Picked up my K-x recently for the first time in months (it's my back up body). I'm considering using it as the basis for a lightweight kit on a forthcoming holiday.

It had a set of Ni-MH rechargeables in it. It turned on OK, but indicated that the batteries were very low (red outlined oblong on the screen). I wasn't surprised and removed the batteries to charge them.

When I re-inserted them, the camera would not turn on. I charged another set, but got the same result. I then tried a set of lithium batteries - still no response from the camera.

All the batteries show as fully charged on my battery tester.

I can't find the instruction book at the moment - I think it might be in the loft - a job for tomorrow. In the meantime I thought I'd tap into the knowledge here on the forum.

Any thoughts on how I get the camera working again?

percy

Link Posted 11/01/2016 - 08:11
The K-x was known for this issue with rechargeable batteries and it caused me a lot of problems when I had mine. I ended up using lithium batteries. They were just fine and lasted a long time.

OldTaffy

Link Posted 12/01/2016 - 11:25
I also use lithium batteries in my K-x. The rechargeable Ni-MH (eg eneloop 3UTGB) are excellent for those who use their K-x a lot and often. I had problems because sometimes weeks go by without use, and even eneloops seemed to lose too much charge when idle. With lithiums, I notice that the screen sometimes warns of 'low batteries' (orange indicator) with part-used lithium batteries, but if the camera is turned off for a minute or so, the indicator then shows green.

I do not know why your camera should remain unresponsive when fresh batteries were fitted. Have you tried taking the batteries out, leaving it overnight (or longer) and then putting fresh ones in? I assume that you had turned the camera to 'OFF' before removing or changing batteries.

Martin
A few of my photographs in flickr.
Lizars 1910 "Challenge" quarter-plate camera; and some more recent stuff.

redbusa99

Link Posted 12/01/2016 - 17:42
check contacts for corrosion perhaps
odd lens or 2

Flickr

SteveF

Link Posted 12/01/2016 - 20:08
Thanks for the suggestions. I had done all those things.

For some reason (desperation, maybe?) I dug out another different set of NiMHs, charged them, inserted them, and normal service was resumed! Who knows why?

Anyway, I'm a happy bunny.

One more question to fellow users - do you leave the battery choice in the menu on Auto or do you set it to the appropriate battery type?

senn

Link Posted 13/01/2016 - 16:01
The problem is well known with K-x ..
- if you're still at 1.0 version of the firmware, update it,
- leave battery choice on "auto", that has no consequence,
- use Energizer AA NiMH rechargeable batteries

nonetheless K-x is a great gear ..
senn
my flickr gallery
my PPG

JAK

Link Posted 13/01/2016 - 21:11
Add a Comment
You must be registered or logged-in to comment.