DA* 50-135 motor failure


josiahk

Link Posted 07/07/2013 - 12:10
Hi everyone. A couple of years ago I bought a second hand DA* 50-135mm lens, which I have enjoyed very much. Unfortunately, it has developed a problem. The auto focus now just doesn't seem to work. I believe this is probably the SDM motor failing, as I'm sure I have read is a fairly common problem with the older versions of this lens.

Can anybody help me with what I should do now? Obviously it is outside of any warranty period, so I am looking at paying to get it fixed I guess. Money is limited though, so I have to be careful.

Any recommendations for who I should go to? I live in West Wales and don't drive, so getting anywhere is problematic.

Many thanks,
Tim.
Narcoleptic with a camera

punkrockemo

Link Posted 07/07/2013 - 13:00
If you are feeling brave you could try and fix it yourelf.

http://ricehigh.blogspot.com/2011/01/repair-stuck-sdm-yourself.html

I think i would be a bit scared though, I seemed to recal a couple of people who had sent theirs for repare saying that it came back working faster than before

Mike-P

Link Posted 07/07/2013 - 13:00
I bought a 50-135mm with non working SDM a few months ago on purpose because it was cheap. It was repaired by JPS Solutions at a charge of 160. As you are a PU member you get 20% discount LINK so in the end it worked out at around 130.

On the plus side the lens came back much much better than previous working 50-135's I have had ... so much so I sold the Sigma 50-150mm f2.8 I was using.
No equipment list here but thanks for taking an interest. My Flickr

matwhittington

Link Posted 07/07/2013 - 15:22
Have you tried cleaning the contacts? worth a try. I also have a lens with temperamental SDM, but I find that if I mount the lens and then (reasonably) gently spin the focus ring back and forth from closest to furthest a few times, the SDM works again; not sure why but it does the job for me...

Cheers
Mat W

My Flickr: link

josiahk

Link Posted 07/07/2013 - 16:04
Thanks for the advice everyone. The motor failed after I took the lens with me to Greece, so I'm thinking it was not a big fan of the heat

I don't have the bottle to open it up myself, so I will check out the JPS option.

Thanks again,
Tim.
Narcoleptic with a camera

SteveF

Link Posted 07/07/2013 - 21:03
Tim

Like Mike, I had my copy fixed at JPS a couple of years ago. All perfectly straightforward and pretty fast.

I am intrigued by your location, as I studied at St David's University College (as it was then then) in the early 70s.

josiahk

Link Posted 07/07/2013 - 21:38
Ah SDUC, later to be University of Wales, Lampeter, and now Trinity Saint Davids. I too did my degree years there, and later moved back to the area after finding London too 'much'. It's a lovely bit of the world, especially with the weather we are getting right now
Narcoleptic with a camera
Add a Comment
You must be registered or logged-in to comment.