DA* 16-50 2.8 on K30 Problem


punkrockemo

Link Posted 11/03/2013 - 17:54
I have just taken delivery of 2nd hand DA* 16-50 from a reputable retailer. On testing it have found that The Auto focus is not working on my K30.

I have checked that the AF switch on lens is set to AF, have also tried the AF switch settings on camera on both AF.S and C. I have also tried another lens on the camera to check AF is working although its not a SDM lens as the 16-50 is my first SDM lens.

Before i send it back to get it repaired is there anything else i should try

ilovesaabs

Link Posted 11/03/2013 - 18:57
do you only have a K-30?

if you had another AF camera you could try on that would help root out the probable cause....

does the focussing ring move when the lens is off the body?

also suggest locating a nearby member.....you don't give your location but it's worth casting the net just in case. When my DA*60-250 went on the blink a second time - I just went to the first person I saw with a Pentax body and asked if I could borrow it for a second....

lastly, if you have a jeweller's screwdriver use that to try to turn the AF screw in the lens... that did the trick on my DA*
AKA Welshwizard/PWynneJ
Assorted Pentax/Nikon/Mamiya stuff

punkrockemo

Link Posted 11/03/2013 - 20:44
I have now tried on it my K-X (which is still for sale) and still no luck.

The focusing ring moves freely when of the body.

Thanks for advice, wanted to make sure i was not missing something obvious before contacting shop.

Mark

ilovesaabs

Link Posted 13/03/2013 - 11:06
Ok good luck Mark, hope it gets sorted.
AKA Welshwizard/PWynneJ
Assorted Pentax/Nikon/Mamiya stuff

punkrockemo

Link Posted 31/03/2013 - 21:00
Lens back and working fine

Good service from London camera exchange who got the lens fixed quickly without any trouble.

had a play with it today, its a very nice lens
Add a Comment
You must be registered or logged-in to comment.