weird bug with my K5


ZOOM1

Link Posted 14/11/2011 - 03:41
HI
My K5 has started to develop a weird bug :s
It keeps thinking it has an SD card inside the camera when it doesnt.
When it doesnt have an memory card inside it would show a memory card error or it would show how much shots are left and then goes and show a zero count, when picture taken it would show a message saying unable to save image.

firmware 1.03
sd card using 7 days shop 32GB SD Card.

Kind Regards

Mannesty

Link Posted 14/11/2011 - 07:47
It's conceivable, but unlikely, that you have two problems, one with the card slot, and possibly a faulty SD card.

There would seem to be a problem with your camera's SD card slot as it shows a card present, when there is none.

You could also try another card.

I wouldn't even try a firmware update to V1.11 until this issue is fixed.

If the camera is still in warranty, talk to your supplier.
Peter E Smith

My flickr Photostream

Eagle12

Link Posted 14/11/2011 - 09:56
I have a "lesser" problem with the SD card in my *istDL.
4Gb SDHC card, camera reads 346 shots when in Raw mode and counts down after each shot as normal. Switch to Jpeg and counter reads 999 but will not count down. (firmware 1.03, which allows the camera to use SDHC cards).
It's not that serious it's just annoying and I can live with it. But are there any suggestions as to what could be wrong?

Mannesty

Link Posted 14/11/2011 - 10:18
Eagle12 wrote:
I have a "lesser" problem with the SD card in my *istDL.
4Gb SDHC card, camera reads 346 shots when in Raw mode and counts down after each shot as normal. Switch to Jpeg and counter reads 999 but will not count down. (firmware 1.03, which allows the camera to use SDHC cards).
It's not that serious it's just annoying and I can live with it. But are there any suggestions as to what could be wrong?

There is nothing wrong. The counter can only display 3 digits, so 999 is the maximum it can display. Your camera & card combination can store more than 1000 .JPG images, so it'll stay at 999 until it can display a smaller number.
Peter E Smith

My flickr Photostream
Last Edited by Mannesty on 14/11/2011 - 10:18

Eagle12

Link Posted 14/11/2011 - 10:39
Thank you for explaining that Peter. I'm a happy little bunny now.

ZOOM1

Link Posted 14/11/2011 - 14:55
I have tried other SD Cards and it works fine. Take it out and it would still think it has a memory card in it and displaying a memory card error message. Yeah it should still be under warranty. Bought it back in November 2010 but i had to send it in for the stains issue and got a replacement K5 dated Feb 2011.
It's just annoying knowing this minor problem. Apart from this issue, my k5 is great!

Mannesty

Link Posted 14/11/2011 - 15:09
ZOOM1 wrote:
I have tried other SD Cards and it works fine. Take it out and it would still think it has a memory card in it and displaying a memory card error message. Yeah it should still be under warranty. Bought it back in November 2010 but i had to send it in for the stains issue and got a replacement K5 dated Feb 2011.
It's just annoying knowing this minor problem. Apart from this issue, my k5 is great!

Are you saying that, aside from the camera showing a card present when it isn't, you have the card problem with only one card?

If so,

1: Try formatting the card in the camera.
2: Check all your cards have the lock switch on them and that they are set fully to the unlocked position. If any are missing, it's likely to be inside your camera.
Peter E Smith

My flickr Photostream
Add a Comment
You must be registered or logged-in to comment.