Tokina lens, not functioníng properly


Leech

Link Posted 11/03/2008 - 19:23
Ok here goes.

Last fall I bought a Tokina 28-70 f2.6-2.8 lens used over ebay.

But it have never worked properly on my K10D.
When I turn on my Pentax, it asks for the focal length (like it thinks it's a manual lens)

The lens works fine until it hunts and the focus ring goes to infinity or 0.7 (the closest focus range). When it hits the camera stops sensing which aperture the lens is set to (even though it's set to A).

To get the Camera to sense which aperture the lans have, I have to switch it to manual, switch the lens to manual, turn the focus ring a bit, and the set it all to Automatic again. ???

I haven't had the chance to try the lens on another K10D.. So is there anyone who have any idea of what I can do ?

Beacuse I REALLY like this lens
K10D, Pentax 18-55mm, Pentax 50mm f1.7 M, Pentax DA* 300mm f4, Da* 50-135mm f2.8, DA* 16-50mm f2.8, Tamron 28-70mm f2.6-f2.8

Leech

Link Posted 13/03/2008 - 07:40
None who knows if it can be a connecting point or anything ?

Anyone who have this lens where it works without any problems ?
K10D, Pentax 18-55mm, Pentax 50mm f1.7 M, Pentax DA* 300mm f4, Da* 50-135mm f2.8, DA* 16-50mm f2.8, Tamron 28-70mm f2.6-f2.8

Mannesty

Link Posted 13/03/2008 - 08:28
Thoroughly clean the contacts on the lens and camera body.

I use a paper kitchen towel with one drop of WD40 (water repellant lubricant). Then use another paper towel to dry the contacts. Try again.

You have to prepare for the possibility that this was the reason the lens was on ebay in the first place. If it doesn't work, ask for a refund.

I assume that you have another AF lens which works properly.
Peter E Smith

My flickr Photostream

Peter Elgar

Link Posted 13/03/2008 - 14:54
Did you go into the Custom Menu and scroll down to find 'Aperture Permitted or not' : Put it to 'Aperture Permitted' : when I put my manual focus lenses on and the shake reduction lever is 'ON' then the purple thing comes up with the focal length in it and you can change it to what you want.
been a member of Pentax Club since the Ron Spillman era! Got COMPUTERISED at last - DIGITISED? Taken the PLUNGE - BUT FILM STILL RULES !!!

Leech

Link Posted 16/03/2008 - 20:54
-> Mannesty - I have now tried to give it a good cleaning. Which unfortunately didn't do the trick.

-> Peter Elgar - Yes I have set the "Aperture Permitted" in the custom menu.

thx. guess I'll have to try and send it to tokina og smth like that.
K10D, Pentax 18-55mm, Pentax 50mm f1.7 M, Pentax DA* 300mm f4, Da* 50-135mm f2.8, DA* 16-50mm f2.8, Tamron 28-70mm f2.6-f2.8
Add a Comment
You must be registered or logged-in to comment.