Mark on photos


davidruane

Link Posted 11/01/2017 - 13:35
Not very descriptive I admit.

I now have two marks on the top left hand corner of each photo I take. The camera is a K-50, and these marks occur on any lens I use.
I`m very much a novice to this so I don`t want to cause any damage but I`d appreciate any guidance on where I could clean (if possible).

I`ve cleaned the lenses, viewers and air blown the inside of the camera - is there anywhere else ?

Many thanks

David

Today is a great day - they always are if you wake up

scarr1

Link Posted 11/01/2017 - 13:47
I would guess that it is something on the sensor, especially if its in the same area of an image, and using different lenses.
I'm sure someone more knowledgeable will be along soon, and possibly give you advice on how to clean it, if that's what it is.
I have never leaned a sensor, so would be reluctant to offer advice.

Dariusz

Link Posted 11/01/2017 - 15:13
I have never had K-50 in my hands, but it is possible there is some "sensor cleaning" mode within its menu. It would expose the sensor (lens detached) giving you a good opportunity to use your air blower. If it won't help, wet sensor clean is required
K-3II & 5IIs. DA* 300/4, DA* 55/1.4, HD DA 35/2.8 Macro Limited (Silver!) & Samyang 16/2. AF 540 FGZ II AW flash.

davidruane

Link Posted 11/01/2017 - 15:41
Many thanks - now fixed.

I had a look at various other previous posts and took guidance from them.
Sensor has now been cleaned and whatever is was has gone
Today is a great day - they always are if you wake up
Add a Comment
You must be registered or logged-in to comment.