K5 4-way controller oddity ?


davidwozhere

Link Posted 13/06/2016 - 18:14
I rarely change the white balance but had occasion to do so today. Nothing happened. Nothing happened for any of the other four positions either. Live View and menu worked OK so I looked at the other settings. I rarely use selectable focus point either but this time I had had it on SEL for a one-off task. Changing this back to "Point" (or indeed putting it on Auto) re-enabled the 4-way switch -- it simply doesn't operate when the focus switch is on 'Select'
Is this just my camera, a bug of some sort or is there a reason for it?
Both the *istDS and the K5 are incurably addicted to old glass

My page on Photocrowd - link

wvbarnes

Link Posted 13/06/2016 - 18:22
That's how it works. I've in turn accidentally had select instead of centre spot in past so check top LCD by pressing left side AF mode button from time to time.

IF you are currently in sel AF point mode the bottom right on back button (also card slot select) turns function back to allow WB etc.

smudge

Link Posted 13/06/2016 - 18:42
When you are in 'sel' the 4 way switch is changing the selected focus point so cannot perform it's other functions.
Regards, Philip

davidwozhere

Link Posted 13/06/2016 - 19:08
Smacks head for idiocy !! I had tried to consider if it was caused by conflicting functions, but I clearly missed the obvious. Thank you.
Both the *istDS and the K5 are incurably addicted to old glass

My page on Photocrowd - link

GlynM

Link Posted 13/06/2016 - 19:22
wvbarnes wrote:

... IF you are currently in sel AF point mode the bottom right on back button (also card slot select) turns function back to allow WB etc.

That sounds like the K-3. On the K-5 the OK button acts as the switch between the 4-way buttons selecting the focus point or the function menus when AF is set to "Sel":




You have to hold the OK button in for around a second until the camera beeps for the switch to take place.


edit:
Also a little 4-way icon on the bottom left of the viewfinder shows when the 4-way buttons are being used for AF point selection and is turned off when the 4-way buttons are being used to select function menus.

Glyn
Last Edited by GlynM on 13/06/2016 - 19:34

pentax

Link Posted 14/06/2016 - 11:31
I Have had the same problem on the K3 11. I now know what II was doing Wrong.
Derek

davidwozhere

Link Posted 14/06/2016 - 22:25
I'm rather glad I asked that question now. Just goes to show, 'there's no such thing as a daft question'....... even when you thought you WERE daft.
Both the *istDS and the K5 are incurably addicted to old glass

My page on Photocrowd - link
Add a Comment
You must be registered or logged-in to comment.