K20D oddity


Mannesty

Link Posted 05/09/2010 - 00:29
Today, whilst playing, I noticed the following odd behaviour on my K20D.

The setup:-

K20D + 3 x Kenko extension tubes + DA* 300mm lens

The objective:-

I wanted to see if I could get similar results with the above setup as I was getting with the Sigma 180mm Macro (no tubes).

The problem:-

When reviewing the few images I took I used the rear e-dial to magnify the image, then I used the 4 way controller to pan the magnified image.

The 4 way controller would not scroll the image, I had to press and release the controller to pan the image.

If I removed the tubes and lens, the image panned fine. If I refitted the lens with no tubes, the image panned fine. I refitted the tubes and it wouldn't pan.

Anybody else noticed this behaviour with perhaps manual lenses?
Peter E Smith

My flickr Photostream
Last Edited by Mannesty on 05/09/2010 - 00:30

Anvh

Link Posted 05/09/2010 - 18:44
Peter I see you've more so I'm curious to know if it does the same with your K10D and the other K20D.
Stefan


K10D, K5
DA* 16-50, DA* 50-135, D-FA 100 Macro, DA 40 Ltd, DA 18-55
AF-540FGZ
Last Edited by Anvh on 05/09/2010 - 18:44

Mannesty

Link Posted 05/09/2010 - 22:11
I do have a K10D Stefan, but its in UK and I am in Spain so I can't test it. It was not important enough for me to test my other K20D, but I will. I fully expect that it (K20D) will exhibit exactly the same behaviour.

I notice that you also have a K10D. If you also have extension tubes, perhaps you could try a lens and see if it's the same for you.

BTW: This behaviour was only really evident when I passed my right arm over my left shoulder and then between my legs before reaching for the shutter button. Let us know how you get on with your test.
Peter E Smith

My flickr Photostream
Last Edited by Mannesty on 05/09/2010 - 22:17

Smeggypants

Link Posted 06/09/2010 - 03:43
K20D works fine here with manual lenses and/or extension tubes
[i]Bodies: 1x K-5IIs, 2x K-5, Sony TX-5, Nokia 808
Lenses: Pentax DA 10-17mm ED(IF) Fish Eye, Pentax DA 14mm f/2.8, Sigma 17-70mm f/2.8, Pentax-A 28mm f/2.8, Sigma 30mm F1.4 EX DC, Pentax-A 50mm f/1.2, Pentax-A 50mm f/1.4, Pentax-FA 50mm f/1.4, Pentax-A 50mm f/1.7, Pentax DA* 50-135mm f/2.8, Sigma 135-400mm APO DG, and more ..
Flash: AF-540FGZ, Vivitar 283

Mike-P

Link Posted 06/09/2010 - 05:33
Maybe something to do with SDM lens and A contact tubes?

I know the camera plays up when using a non compatible teleconverter so maybe the same thing.
. My Flickr
Add a Comment
You must be registered or logged-in to comment.