k20d Memory card slot spring wont lock


NeilP

Link Posted 11/11/2009 - 17:48
When I place my memory card in the slot it wont click and lock but returns to the sprung out postion, which means I have to use the slot cover to hold the card in place. Has anyone else had this problem? Do you think its serious enough to go without my camera for 6 or so weeks until it gets repaired and returned from Pentax?
UK Wildlife blog ----- UK Wildlife Facebook page ----- UK wildlife Twitter

fatspider

Link Posted 11/11/2009 - 17:53
I would get the christmas and new year parties out of the way then get it sorted out while the weather is miserable, after all I assume you still have the Lumix. In fact get it off for repair now, the Lumix should be quite adaquate for party pics.
My Names Alan, and I'm a lensaholic.
My PPG link
My Flckr link

MartynUK

Link Posted 19/11/2011 - 17:41
Same problem with K5... just incase anyone searches this post.

The problem turned out to be a piece of the memory card had snapped off in the slot and wouldn't budge. It was lodged in the bottom of the card slot so, although a card could be inserted and could be read, it was being prevented from going right into the slot.

Finally retrieved the broken piece, but now the slot doesn't seem to work at all - I guess it must have been faulty in the first place, otherwise the card wouldn't have got the edge snapped off. So off to Pentax.

Martyn
Martyn

http://www.flickr.com/photos/northamptonshirecouk/

Still27

Link Posted 19/11/2011 - 20:09
I think it is a good idea to leave the card in the slot as much as you can and connect the camera to your computer with the cable, I don't like it on the K5 that you have to SNAP (not a nice word)the cover shut, which has got to weaken something sooner or later.
Bill
K5+Bigma+BushHawk Shoulderpod.
K5+16-50DA* + 10-17DA Fisheye + 50-135DA* + Sigma 70mm Macro + DA35 2.4..
Slik Pro 700DX tripod.
http://www.flickr.com/photos/pixellie/
Add a Comment
You must be registered or logged-in to comment.