K1 firmware update issues


mattox

Link Posted 29/09/2016 - 09:05
I have just uploaded the firmware onto an sd card, inserted it into the camera, pressed menu and power at the same time but it just goes into normal "on" mode, not the update option. Tried it again a million times and still same result. Cant find another way of setting it up in the menu function. Anyone else had this problem or knows a way that I can resolve this problem. Very frustrating!!!!

mcrtchly

Link Posted 29/09/2016 - 09:12
Worked OK for me. Did you format the SD first before copying the .bin file to it?

I've noticed a few things that don't work with this firmware:

1. Disables SR when using electronic shutter in live view

2. Electronic shutter can't be enabled when doing interval shooting (timelapse)
‘Love Adventure, Love Travel, Live Life’

website: www.purplepeakadventures.com
Instagram: www.instagram.com/purplepeakadventures
Youtube: www.youtube.com/purplepeakadventures
Facebook: www.facebook.com/PurplePeakAdventures
Last Edited by mcrtchly on 29/09/2016 - 09:13

cardiffgareth

Link Posted 29/09/2016 - 09:55
Yeah format the card using quick format on PC. Add the .bin file to the root file of the card (This means, just drag and drop it in, don't make a folder for it). Then press and hold the menu button when powering on and don't let go on the menu button, keep it pressed in. Then it'll ask you to confirm the install.

PLEASE PLEASE PLEASE! Make sure your battery is fully charged first!
Gareth
Welsh Photographer

My outfit: K1 gripped - Pentax D FA 24-70mm - Sigma 70-200mm OS HSM - Pentax modified DA* 60-250mm f4 - Irix 15mm Firefly - Sigma 50-500mm - FA 50mm f1.4 - Tamron SP 90mm macro - Pentax AF 540 FGZ Ii

My Flickr
My PPG
My 500px

joostdh

Link Posted 29/09/2016 - 10:03
Format the card with your camera then add the .bin-file from your computer. That should work.

Oh: and the download is in zip-format, don’t forget to unzip that first.
Pentax K-1| Pentax K-01 | D-FA 28-105mm | FA 28mm F2.8 | FA 35mm F2.0 | FA 43mm F1.9 Ltd | FA 50mm F1.4 | FA 50mm F2.8 Macro | FA* 85mm F1.4 | FA 100mm F2.8 Macro | DA* 200mm F2.8 | Pentax AF 540FGZ

JAK

Link Posted 29/09/2016 - 10:58
Yes, it's the Fwdc228b.bin file that has to be extracted from the zip file that has to go in the root directory of the SD card that is in slot 1, not the zip file itself.
The instructions are pretty clear but seem to miss out that step!
John K
Last Edited by JAK on 29/09/2016 - 10:58
Add a Comment
You must be registered or logged-in to comment.