K05 vs K50 and change aperture - manual ring


Jan99

Link Posted 20/09/2017 - 19:43
Hi.
I have an old lens without A-mark, where i can change aperture ring manually.
However I can not set 'manual aperture move allowed' on the K05, but it works on K50.
Customer menu 4 on K05. The parameter is 'grey', can not change.
It must be some parameter blocking the K05, what could it be?
Anyone who knows?

Jan99

Link Posted 20/09/2017 - 20:06
Now I have found it.
Menu Point 27 must be YES to allow aperture change.

Thank's any way.

Jan99

Link Posted 02/10/2017 - 09:16
Problem with fixed aperture f8.0 on 500 mm mirror objektiv.
How can I change exposure time and get the camera to change ISO according to exposure time.
The only way seems to be to manually change ISO.
Anyone got another way to do it?
M or Tv does not give the possibility to change exposure time with the front or back wheel.

bforbes

Link Posted 02/10/2017 - 11:32
Would you not have to set the camera in manual mode and use the green button to obtain an exposure
Barrie
Too Old To Die Young

http://www.pentaxphotogallery.com/artists/barrieforbes
https://www.flickr.com/photos/189482630@N03/

johnriley

Link Posted 02/10/2017 - 11:45
As long as using aperture ring is set to permitted, the f/8 fixed aperture is simply open aperture. The camera will work fine in manual and Av. I have a feeling IIRC that whatever other mode is set the camera will still operate only in Av unless set to M.
Best regards, John

petrochemist

Link Posted 02/10/2017 - 13:13
Jan99 wrote:
Problem with fixed aperture f8.0 on 500 mm mirror objektiv.
How can I change exposure time and get the camera to change ISO according to exposure time.
The only way seems to be to manually change ISO.
Anyone got another way to do it?
M or Tv does not give the possibility to change exposure time with the front or back wheel.

This is the case with practically all mirror lenses. You can of course adjust shutter speed with ND filters as well as play with the ISO.
IIRC TAV mode with auto ISO should work OK for getting the settings you want.
Mike
.
Pentax:K5ii, K7, K100D, DA18-55, DA10-17, DA55-300, DA50-200, F100-300, F50, DA35 AL, 4* M50, 2* M135, Helicoid extension, Tak 300 f4 (& 6 film bodies)
3rd Party: Bigmos (Sigma 150-500mm OS HSM),2* 28mm, 100mm macro, 28-200 zoom, 35-80 zoom, 80-200 zoom, 80-210 zoom, 300mm M42, 600 mirror, 1000-4000 scope, 50mm M42, enlarger lenses, Sony & micro 4/3 cameras with various PK mounts, Zenit E...
Far to many tele-converters, adapters, project parts & extension tubes etc.

.[size=11:].Flickr WPF Panoramio

johnriley

Link Posted 02/10/2017 - 13:30
When the aperture ring is not set to A, the camera will only operate in Av mode, unless set to M, B or X. So all other modes will only give you Av (aperture priority) regardless of setting TAV or any other auto mode.
Best regards, John
Add a Comment
You must be registered or logged-in to comment.