Jessops SV-8 Slide Viewer & Boots Slides


JPC1970

Link Posted 14/05/2009 - 14:37
I'm not sure if this is in the right forum but here goes.

I bought a jessops SV-8 slide viewer 2 weeks ago and have been waiting with baited breath for my first set of slides to come back from my new MX.

I only bought the cheapest processed paid slides I could get which were the boots own brand ones to check the camera's shutter speeds mainly.

I have just got the slides back today and they are mounted in cardboard and plastic which doesn't fit in the viewer.

Has anyone else had this problem ?

Which slide film should I get to be sure that they will fit into the viewer when mounted ?

Thanks
Jason
K30 & 18-55mm WR.
Last Edited by JPC1970 on 14/05/2009 - 14:38

hefty1

Link Posted 14/05/2009 - 14:54
The film has nothing to do with it - you could send the same film to 10 different labs and get your results back in 10 different types of mounts, depending on what each lab chooses to use.

Any chance of a pic of the viewer showing the slide slot?
Joining the Q

JPC1970

Link Posted 14/05/2009 - 14:59
Don't I feel the numpty now.

I was just about to take a pic of the viewer and I noticed a slot on the back which the slides fit into. It also has 2 slots of the sides one either side which I thought were the ones to put the slides in.

Thanks Hefty

Jason
K30 & 18-55mm WR.

hefty1

Link Posted 14/05/2009 - 15:00
Oh well, at least it's sorted.

Now to find out if the MX behaved itself...
Joining the Q

JPC1970

Link Posted 14/05/2009 - 15:31
Looks like the MX is firing all shutter speeds OK.

I fitted that shutter lock you sent me Hefty, Thanks. Job and a half keeping the ball bearing in place, didn't have any grease so used a tiny bit of soap to hold it onto the spring.

Jason
K30 & 18-55mm WR.

hefty1

Link Posted 14/05/2009 - 20:14
Good stuff.

Glad it's all worked out, now you can concentrate on finding your favourite film...
Joining the Q
Add a Comment
You must be registered or logged-in to comment.