DNG Artifact


Gravelrash

Link Posted 28/11/2013 - 17:09
I am getting a strange artifact at the right of my pictures when saving as RAW DNG. This is the same in RAW+ but the jpg doesn't show it and it is happening in Picasa as well as Photoplus X5 but not in Photoshop CS5.

Doesn't happen with the K-r DNG files.

Any clues?



Steve

Sometimes I'm serious and sometimes not, but I consider sarcasm an artform. Which is it today?

Gamka

Link Posted 28/11/2013 - 17:35
Are you also getting a vertical black stripe on the left?

And what about RAW PEF files?

In the various applications can you select all of the good part of the image and then get the actual size of the selection and does it match the camera resolution or is it less?
Last Edited by Gamka on 28/11/2013 - 17:35

alfpics

Link Posted 28/11/2013 - 17:38
Hi Steve
Can you clarify something; you say its happening with RAW DNG, but doesn't happen with K-r DNG. Do you mean its happening with RAW PEF - if that is so then it is probably that Picasa and Photoplus X5 aren't/ weren't totally up to speed with that file format. Basically the sensor is larger than the saved image file, so there are a few spare pixels around each edge that are not used in the final image, and it could be that the RAW converter isn't quite making the crop as it should
Not sure if that helps or not
Andy

PS - classy 'Hog'!
Andy

johnriley

Link Posted 28/11/2013 - 17:44
This sort of thing happens when the RAW converter sees bits of the file that aren't the image. It tends not to happen with Photoshop and I presume it doesn't with Pentax's own software either.

You could try seeing if the programs it does happen in have any updates available.
Best regards, John

Gravelrash

Link Posted 28/11/2013 - 17:51
Thanks for responding guys. I haven't tried PEF because I don't use software that supports it. I am referring to DNG in both the K-r and K-5II. The K-r doesn't show these artifacts but the K-5II does.

Gamka, you are right, there is a black line on the left of the image and both that and the coloured artifact on the right appear to be in excess of the normal image size. Hadn't noticed until you mentioned it.

Edit... Think you and I posted at the same time John. I have checked the Pentax software and you are correct, it doesn't corrupt in that. Guess I will have to hope Picasa updates soon because I find it suits me for a general 'go to' programme for viewing images and keeping track of them. Weird that it affects the K-5 and not K-r.
Steve

Sometimes I'm serious and sometimes not, but I consider sarcasm an artform. Which is it today?
Last Edited by Gravelrash on 28/11/2013 - 18:04

steven9761

Link Posted 28/11/2013 - 18:05
Your K-5II is totally defective - I'll take it off your hands for a fiver!!

Gamka

Link Posted 28/11/2013 - 18:07
Photoshop supports PEF
Gravelrash wrote:
Thanks for responding guys. I haven't tried PEF because I don't use software that supports it. I am referring to DNG in both the K-r and K-5II. The K-r doesn't show these artifacts but the K-5II does.

Gamka, you are right, there is a black line on the left of the image and both that and the coloured artifact on the right appear to be in excess of the normal image size. Hadn't noticed until you mentioned it.

Photoshop supports PEF.

A little "blue sky" thinking
The sensor is often larger than the resolution and a central area used for the image. Does the RAW format include some of the data from those pixels or have them set to a fixed value - then when the processing happens the software is told to use specific rows and columns based on the camera. Could it be that the software is not reading the data correctly and using parts that it should not? Especially as you say those bars are in excess of the normal resolution.

Would the data outside the normal be needed to get hi-quality JPGs as that needs data from adjoining pixels and if missing the edges of the JPG may not bee too good.

Are you using the right Plug-in for the camera body?
Last Edited by Gamka on 28/11/2013 - 18:08

Gravelrash

Link Posted 28/11/2013 - 18:07
I couldn't possibly take your money Steve I'll just soldier on
Steve

Sometimes I'm serious and sometimes not, but I consider sarcasm an artform. Which is it today?

steven9761

Link Posted 28/11/2013 - 18:10
Gravelrash wrote:
I couldn't possibly take your money Steve I'll just soldier on

Oh, well!... I'll just have to see if there's a kindly barmaid who is prepared to exchange my fiver for some beer then!!

They do say that God loves a trier, though!!

Gravelrash

Link Posted 28/11/2013 - 18:12
I think your right Gamka. I was using DNG because it appeared to be supported in more software. I can work round the issue but I was worried I had a fault in the camera which is new and barely had any use yet.
Steve

Sometimes I'm serious and sometimes not, but I consider sarcasm an artform. Which is it today?

ChrisA

Link Posted 28/11/2013 - 18:15
I saw exactly the same sort of thing with Picasa shortly after the K-5 came out.

It went away in a later version. Surprised they haven't sorted it yet, though, the K-5ii has been out for a while.
.
Pentax K-3, DA18-135, DA35 F2.4, DA17-70, DA55-300, FA28-200, A50 F1.7, A100 F4 Macro, A400 F5.6, Sigma 10-20 EXDC, 50-500 F4.5-6.3 APO DG OS Samsung flash SEF-54PZF(x2)
.

tyronet2000

Link Posted 07/12/2013 - 10:35
I solved the problems I had with Picasa and other programmes in the following manner:

Backed up things I wanted to keep.

Did a Full system restore.

Reinstalled programmes, e.g. Lightroom 5 etc.

DID NOT REINSTALL PICASA

Updated reinstalled programmes

DID NOT REINSTALL PICASA
Regards
Stan

PPG
Last Edited by tyronet2000 on 07/12/2013 - 10:37

andrewk

Link Posted 07/12/2013 - 11:19
Gravelrash wrote:
Guess I will have to hope Picasa updates soon because I find it suits me for a general 'go to' programme for viewing images and keeping track of them.

You could always use IrfanView instead as a viewer. It displays preview images from all of the DNGs I've used without adding stripes on the sides (K200D and K30).

Andrew
Flickr photostream

LennyBloke

Link Posted 07/12/2013 - 12:26
I too had the same issues with the K5 early on, but it appears it was fixed in an update.

I now have the same problem with the K5iiS.

I guess a Picasa update will fix it in the future?
LennyBloke

tyronet2000

Link Posted 07/12/2013 - 13:34
I did like Picasa, especially the straighten tool so once I hear it is 'fixed' I might install it again
Regards
Stan

PPG
Add a Comment
You must be registered or logged-in to comment.