Disappearing rear screen information, has anyone had this problem?


Gedski

Link Posted 27/07/2016 - 12:26
K-50 being used with Tamron 70-300mm f4-5.6 Di LD Macro lens. Purchased new on Friday last. All went well until this morning. On switching on the K-50 I saw that instead of the aperture value showing , for instance, f5.6, it showed f-- and was continually flashing on and off.

Also, when I changed the modes using the top controller wheel the mode remained on Av, with the exception of manual mode. I cleaned the contacts on both the lens and the camera and the problem, for a few minutes, seemed resolved. Then the problem returned. The lens is now awaiting collection from the photographic shop from where I bought it.

It would be helpful to me if anyone out there has any experience of a similar problem as I am wondering if the problem might be with the camera or the lens or both. I intend to 'have a go' using the 18-55 kit lens to see if the problem might manifest itself with that. Muchly thankings.

johnriley

Link Posted 27/07/2016 - 14:52
You're right to check that the other lens works or not, but it will only take a moment to find out.

F-- indicates that the camera can't read the lens aperture. One reason is poor contact, but the simpler reason can be a lens with an aperture ring where the ring is not set to "A". If the Tamron has an aperture ring, make sure it is set to "A".
Best regards, John

Gedski

Link Posted 27/07/2016 - 16:35
johnriley wrote:
You're right to check that the other lens works or not, but it will only take a moment to find out.

F-- indicates that the camera can't read the lens aperture. One reason is poor contact, but the simpler reason can be a lens with an aperture ring where the ring is not set to "A". If the Tamron has an aperture ring, make sure it is set to "A".

Muchly thankings John, I certainly didn't know about the 'A' thing. After trying to sort it all out, I rang the retailer from whom I bought the 'stuff', not SRS. It has been mutually agreed to send it all back and they can sort it. It gets collected tomorrow.

It is all rather an anti climax after me going back to the K-50 after my problems of a year or two ago, a lot of which were down to my poor knowledge of photography in general and Pentax workings in particular. I was just getting some half decent BIF shots as well using the Tamron 70-300mm lens. Hopefully, it shall all be sorted out in a week or two.
Add a Comment
You must be registered or logged-in to comment.