DA 17 - 70mm focus issues


Mike-h

Link Posted 04/03/2019 - 21:38
I've had a DA 17 -70mm on my k-5 II for a few years now and it takes excellent photos. However, about three years ago it developed a problem where it wouldn't focus when it was zoomed in from about 45mm to 70mm. As soon as you zoom back out the AF works, but by this time you had generally missed the shot. I sent it away to Johnsons Photopia and it came back working. It has continued to work for about 18 months but it has now developed the same problem again. My DA 55 - 300mm works absolutely fine so I am assuming it is the lens. I have cleaned all the contacts thoroughly and updated the firmware but there is no improvement. I am reluctant to spent another 200 on this lens as it will go along way towards a new one. Before I take the plunge I thought it would be worth asking the question if anyone else had had this problem and found a simple solution to it?

Mike-P

Link Posted 04/03/2019 - 22:00
It's actually quite a common problem with the DA 17-70mm, I believe it's something to do with the SDM. As far as I am aware there isn't a simple solution ... it needs repairing.
. My Flickr

davidstorm

Link Posted 04/03/2019 - 22:00
This issue is common on the DA 17-70, they have inherent design faults which cause the symptoms you are describing. It's not a question of whether you will have focus issues with this lens, it's a question of when.

The DA 17-70 is a very good lens when working correctly, but it's too prone to fail and I would steer clear of buying another one and would go for a more reliable alternative instead. The Sigma 17-70's are very good, both the current and previous versions. Sorry if this sounds a bit negative towards the Pentax lens, but I'm just giving an opinion based on previous ownership and also from other people I know that have had issues with the DA 17-70.

Regards
David
Flickr

Nicola's Apartments, Kassiopi, Corfu

Some cameras, some lenses, some bits 'n' bobs

ilovesaabs

Link Posted 05/03/2019 - 14:31
I was about to buy one when my 16-50 first failed, it was in Jessops (Mk1) in Richmond. Before passing the money I asked to check it on a camera and it failed to work....

what blights the lens even further that it's SDM only, no option for screw drive...
AKA Welshwizard/PWynneJ
Assorted Pentax/Nikon/Mamiya stuff
Add a Comment
You must be registered or logged-in to comment.