Calling K5ii/ K5iis owners - loose shutter


Pentaxonian

Link Posted 31/12/2012 - 21:54
Got my K5iis today from SRS. Fantastic in everyway I was hoping it would improve upon the K5.

However my shutter button is a bit loose, making a clickety sound with any slight touch

Should I be concerned? Should I ask SRS for a swap?
K5iis and a couple of lenses.

Smeggypants

Link Posted 31/12/2012 - 23:01
I wouldn't be very happy about it.
[i]Bodies: 1x K-5IIs, 2x K-5, Sony TX-5, Nokia 808
Lenses: Pentax DA 10-17mm ED(IF) Fish Eye, Pentax DA 14mm f/2.8, Sigma 17-70mm f/2.8, Pentax-A 28mm f/2.8, Sigma 30mm F1.4 EX DC, Pentax-A 50mm f/1.2, Pentax-A 50mm f/1.4, Pentax-FA 50mm f/1.4, Pentax-A 50mm f/1.7, Pentax DA* 50-135mm f/2.8, Sigma 135-400mm APO DG, and more ..
Flash: AF-540FGZ, Vivitar 283

judderman62

Link Posted 31/12/2012 - 23:31
hmmm doesn't sound good. I'd get in touch with SRS

pretty sure my K5 doesn't make any such noises. must check my K5 11 that arrived today
- -
Mike

Pentax K5 / Pentax K5 11/ Pentax K200D / Canon Rebel T1 i / Canon 650D / Pentax MX-1 / Fuji XF1 /Fuji X 10 / Canon EOS-M / Canon G10/ Pentax Mz-7 x 2

bettyswolloks

Link Posted 01/01/2013 - 15:02
Mine is the same as my others, nothing odd about it. Give Chris a call mate, he'll have you sorted in no time

judderman62

Link Posted 01/01/2013 - 15:04
yeah checked my newly arrived one and there's no rattle , wobble or anything
- -
Mike

Pentax K5 / Pentax K5 11/ Pentax K200D / Canon Rebel T1 i / Canon 650D / Pentax MX-1 / Fuji XF1 /Fuji X 10 / Canon EOS-M / Canon G10/ Pentax Mz-7 x 2

Pentaxonian

Link Posted 01/01/2013 - 15:09
Cheers, I'll get in touch with SRS, especially that I'm down in London
K5iis and a couple of lenses.

RobE17

Link Posted 01/01/2013 - 15:27
In 2011 I had a similar issue with the K5 that I owned at the time. I sent it off to Johnsons who replaced the shutter button & unit due to a fault.

Hope that helps.
My Flickr Page

Pentaxonian

Link Posted 02/01/2013 - 16:04
Update

Just back from SRS. Looks like this is normal.
BTW, I'm talking about the actual shutter press button. The plastic button feels like it slightly floats on actual mechanism. Which was same for the demo model.
K5iis and a couple of lenses.
Last Edited by Pentaxonian on 02/01/2013 - 16:05

judderman62

Link Posted 02/01/2013 - 16:07
if it makes a noise I would say it is not normal

I have a K5 and a K5 11 - neither make any noise or seem overly loose.
- -
Mike

Pentax K5 / Pentax K5 11/ Pentax K200D / Canon Rebel T1 i / Canon 650D / Pentax MX-1 / Fuji XF1 /Fuji X 10 / Canon EOS-M / Canon G10/ Pentax Mz-7 x 2

Pentaxonian

Link Posted 02/01/2013 - 16:28
Noise is perhaps a strong word.

There is a perceptible sound and it does not affect the use/function.

As I said, it was similar to the shop model.

Anyway back to the K5iis, I am really impressed. I not a pro, but the pictures are visibly sharper and a tiny bit less noisy.

But the main difference is the focussing under low light.
K5iis and a couple of lenses.

judderman62

Link Posted 02/01/2013 - 16:54
glad you're liking it
- -
Mike

Pentax K5 / Pentax K5 11/ Pentax K200D / Canon Rebel T1 i / Canon 650D / Pentax MX-1 / Fuji XF1 /Fuji X 10 / Canon EOS-M / Canon G10/ Pentax Mz-7 x 2

beachboy2

Link Posted 06/01/2013 - 14:38
Pentaxonian wrote:
Noise is perhaps a strong word.

There is a perceptible sound and it does not affect the use/function.

As I said, it was similar to the shop model.

Anyway back to the K5iis, I am really impressed. I not a pro, but the pictures are visibly sharper and a tiny bit less noisy.

But the main difference is the focussing under low light.

My K5iis has the same slight looseness.Doesn't affect performance? But I wonder if weather sealing is affected? Going to Antarctica soon. Would hate to find it's an issue while I'm down there!
cheers
bb2

K5, K20D, Bigma, Sigma EX 105, Sigma EX 10-20, Sigma EX 28-70 F2.8, Sigma Ex 1.4TC,
Pentax 135 F3.5, Pentax 30mm F2.8 , Pentax 50mm F1.7, Pentax 55mm F1.8,
Super Taks: 35mm F3.5, 50mm F1.4, 135mm F3.5, 200mm F4
Vivitar TX 200mm F3.5,Vivitar (Komine)135mm f2.8, Vivitar 2X TC, Vivitar T4 400mm F6.3
Tamron SP 35-80,80-210 F3.8, Helios 44M, Mir 1B 37mm F2.8, Jupiter 9 85mm F2, Chinon 28mm F2.8, 3M-5A 500mm F8 etc etc

Pentaxonian

Link Posted 06/01/2013 - 21:56
I'm told it's because of the O ring seal around the shutter button.

Let us know how you get on with it in Antartica
K5iis and a couple of lenses.
Add a Comment
You must be registered or logged-in to comment.