Bit worrying......


Link Posted 13/12/2020 - 13:57
Setting-up for a macro session (yes, really!), bellows set, camera with (Jessops) 13mm ext. ring, then rear bellows standard ring, 100mmn. D FA Macro.
Subject set, focus set, remote flash with sender & receiver set.

Took a test shot for exposure.....

Nothing, no shutter!

Freshly charged Pentax battery.
Card in.
Cleaned contacts on camera & ext tube.
Tried lens direct to body.
With anything on the camera, lens or ext ring....

With nothing ojn. IT FIRES !!!

Cleaned contacts again.

Ah, what about the SDM bits?

My only SDM lens, Sigma 150-500 on.
(Auto focus whirring in & out like a goodun!)
No shutter at first, but then starts to fire.

Anything else on, Fires!!

Don't understand...

Thoughts anyone please!

The more I look, the more there is to see!


Link Posted 13/12/2020 - 14:10
Sounds like something sticking, try a blower inside with mirror up and then put on a lens and use multi-shot for a bit and see if that helps.


Link Posted 13/12/2020 - 16:37
What was the last thing you used the camera for before setting up for macro? Did you change anything in Custom Settings and didn't change back?



Link Posted 13/12/2020 - 18:05
Thanks chaps!

I think it must have been a one-off who-knows-why sort of a thing.....

All blown out, Rob & it's firing on all speeds/ all variations, as in multi-shot, etc.

Don't think I did, Steve, in fact I don't remember ever using a "custom" setting for anything.....

Anyway, it went ok for the session this afternoon, so we'll see!

Thanks again,

The more I look, the more there is to see!


Link Posted 13/12/2020 - 19:41
My K-1 gave me a blank shot the last time I took it out. It had been unused for months.


Link Posted 29/04/2021 - 12:25
Note to self,

Same again just now.. cured with 150-500 on multi-shot..

The more I look, the more there is to see!


Link Posted 29/04/2021 - 15:56
Perhaps you need a new camera. I've heard mention that Ricoh has recently released a new model that's reputed to be pretty good...

Your problem sounds electrical to me. I once had a TV that behaved much like that. Got worse over time. TV repair man said it was probably a soldered connection starting to fail so he resoldered all he could get to. It worked OK for a while then the bad behaviour returned. I don't have that TV now.

Add a Comment
You must be registered or logged-in to comment.