A colour problem with my K5


Horst

Link Posted 31/03/2016 - 13:44
Hi, Suddenly My K5 Seem to have lost the oranges and yellows . The yellows and oranges show up as a purple-red colour. Also it underexposes somewhat, Possibly because the yellows are missing.

I checked all the settings WB, filters etc. I also reloaded the software.

Yo may think that the sensor has a problem, But:

It doesn't happen when the camera is set to green mode. Then everything is ok.

On any other setting AV, TAV etc it has this problem.

Did any of you encountered a similar phenomena, or is my a first?

Regards, Horst
Last Edited by Horst on 31/03/2016 - 13:45

Mag07

Link Posted 31/03/2016 - 14:25
Might be easier to diagnose if you would post a pic showing the effect. Have you checked the JPG presets? I believe they have no effect on full auto mode but affect every other mode. Maybe something got swapped around accidentally in there?
'Photography...it remembers little things, long after you have forgotten....' (Aaron Siskind)

mille19

Link Posted 31/03/2016 - 15:02
Are you shooting Jpeg or Raw ?

johnriley

Link Posted 31/03/2016 - 15:15
Perhaps you have set a digital filter that removes certain colours? If you have then it will remain set until you change the parameter to "no filter".
Best regards, John

carmagw

Link Posted 31/03/2016 - 16:04
If you're shooting jpeg then I'd check you've not changed the settings for the jpeg output. Took me a while to realise why I had started shooting in B&W once !

Horst

Link Posted 01/04/2016 - 03:59
Thanks for your Comments. But nothing so far helped. I Had Jpeg set to **** and 16 Mp

All filters are out. (No filters)
Here are a couple of pictures. The first one was with the green setting and the yellow is perfect .The other with the SV setting and now its red.

Regards, Horst





Mag07

Link Posted 01/04/2016 - 09:31
This does look like some strange rendering enabled. By JPG settings I meant image setting - those that allow you to select rendering presets for the jpg engine. They are accessible via the pad at the back. On K3 it's the button on the right. Should be in the same position on the K5? The interface looks like that:




Just pick one of regular ones - so natural/landscape etc. Each individual preset can be further adjusted so I'd make sure these settings are at their defaults as well.
'Photography...it remembers little things, long after you have forgotten....' (Aaron Siskind)
Last Edited by Mag07 on 01/04/2016 - 09:34

Algernon

Link Posted 01/04/2016 - 10:57
Try setting the histogram display to RGB.
Take a photo of a white or grey card in daylight with the camera set to daylight or AWB.

The histogram should just show 3 spikes about 2mm wide directly in line vertically.

I would use RAW + JPG although either should work.
--
Half Man... Half Pentax ... Half Cucumber

Pentax K-1 + K-5 and some other stuff

Algi
Last Edited by Algernon on 01/04/2016 - 10:57

layingback

Link Posted 01/04/2016 - 11:04
It's OK in Green mode ....

So if you look in the manual under "Using the (Green) Mode" - p103 in K5, p90 in K5II - it lists the automatic, ie forced, settings in Green mode. the only colour affecting ones are:

White Balance is forced to AWB (Auto) and Custom Image to Bright (and Color Space sRGB). So try those in JPEG and see if the non-Green modes are then OK. If so it has to be one of those White Balance or Custom settings which have been changed inadvertently.

Or give up entirely on JPEG and shoot RAW
My PENTAX Page

MrB

Link Posted 01/04/2016 - 11:05
The EXIF data shows.....

1st image: Image Tone=Bright; White Balance=Auto; White Balance Shift=0

2nd image: Image Tone=Bleach bypass; White Balance=Flash; White Balance Shift=A7 (red)

.....presumably causing the red toning.

Cheers.
Philip

michaelblue

Link Posted 01/04/2016 - 11:15
I had the same problem with my K5, it turned out I'd somehow managed to switch to 'Bleach bypass' in the custom settings (button on the right of the control pad)

I just switched back to 'Natural' and all has been fine since
Regards,
Michael
My new website:link
Last Edited by michaelblue on 01/04/2016 - 11:16

Horst

Link Posted 01/04/2016 - 13:07
Quote:
I had the same problem with my K5, it turned out I'd somehow managed to switch to 'Bleach bypass' in the custom settings (button on the right of the control pad)

I just switched back to 'Natural' and all has been fine since .

That fixed it. thanks to all of you for your info and help.

I thought I had to buy a new camera. I never ever used this button before, but must have accidently touched it and altered the settings.

Thanks again, all of you.

Regards, Horst

Horst

Link Posted 01/04/2016 - 13:25
Now that everything is again in order, I decided to Have one glass of Glen Moray single malt in honor of you guys.

And another one for myself.

Then I go to bed, it is 11:30 pm here in Melbourne.

Regards, Horst

McGregNi

Link Posted 02/04/2016 - 21:10
Glad that's all fixed now ..... So presumably, back in the day, someone accidentally spilled their bottle of bleach, (which they had foolishly taken into their darkroom ) onto their precious film being developed ... And after cursing and swearing they looked again and thought ....'hmm, that's not to bad after all ... I'll make that a new film ' thing '.....but 'spilt bleach' doesn't sound very pro, so how about ' bleach bypass' instead ' ...... And we've been stuck with it ever since .
My Guides to the Pentax Digital Camera Flash Lighting System : Download here from the PentaxForums Homepage Article .... link
Pentax K7 with BG-4 Grip / Samyang 14mm f2.8 ED AS IF UMC / DA18-55mm f3.5-5.6 AL WR / SMC A28mm f2.8 / D FA 28-105mm / SMC F35-70 f3.5-4.5 / SMC A50mm f1.7 / Tamron AF70-300mm f4-5.6 Di LD macro / SMC M75-150mm f4.0 / Tamron Adaptall (CT-135) 135mm f2.8 / Asahi Takumar-A 2X tele-converter / Pentax AF-540FGZ (I & II) Flashes / Cactus RF60/X Flashes & V6/V6II Transceiver

layingback

Link Posted 03/04/2016 - 11:14
You couldn't be more wrong - on every count ...
My PENTAX Page
Add a Comment
You must be registered or logged-in to comment.