Q 02 lens issue


fritzthedog

Link Posted 07/11/2015 - 09:34
I have not used my Q for a few months - it was fine last time I used it.

I put the 02 lens on it yesterday and it just omits a high pitched screech for 10 seconds showing a blank screen. Then the screen comes on but the camera will not fire and the lens will not focus. The camera is fine with the 01 lens attached so must be an issue with the 02 lens

Anybody had any similar issues?

Suspect it may be time for a new lens!

Carl
No matter how many lenses I have owned - I have always needed just one more

SteveLedger

Link Posted 07/11/2015 - 11:11
Q lenses have nice optics but they are poorly constructed lenses overall. I had similar problems with my first 06 after only a week or so. Pentax AU exchanged it right away, no issues since but the lens still feels like a cheap piece of cr*p.

johnriley

Link Posted 07/11/2015 - 13:46
I would check your O2 lens to see if anything is caught anywhere, make sure all the controls turn easily and then make sure the contacts on lens and camera have been cleaned with a dry, soft cloth. Then try again. If there's still a problem, then back to be fixed I think.

They don't look badly made to me, the finish seems excellent. They are very light of course, but that's inevitable given their small size.
Best regards, John

michaelblue

Link Posted 07/11/2015 - 17:48
SteveLedger wrote:
Q lenses have nice optics but they are poorly constructed lenses overall. I had similar problems with my first 06 after only a week or so. Pentax AU exchanged it right away, no issues since but the lens still feels like a cheap piece of cr*p.

.... a bit like canon lenses then
Regards,
Michael
My new website:link
Last Edited by michaelblue on 07/11/2015 - 17:48

SteveLedger

Link Posted 07/11/2015 - 20:51
johnriley wrote:

They don't look badly made to me, the finish seems excellent. They are very light of course, but that's inevitable given their small size.

John, to me they are cheap plasticky, sloppy and need handling with extra care. The focus ring in particular flops around on them all. The 06 requirement to 'switch' it into the extended position before you can even use it has the tactile feedback of something internal breaking, it's a horrid sound and sensation which puts me off using it and may have contributed to the first one breaking within the first week. I don't know why it was not engineered to 'switch on' more gracefully, it doesn't feel like a decent lens at all and certainly not for the price tag [at the time].
The 05 toy lens is properly named, it is relatively cheap and it is nasty, like a funny lens from a child's toy camera.
Add a Comment
You must be registered or logged-in to comment.