Problem with Pentax Digital Camera Utility Program


Grayboy

Link Posted 03/08/2010 - 16:03
Hi - my first post so apologies if its in the wrong place.

I am using the Pentax Digital Camera Utility 4 software supplied with my brand new K7 to view and tweak my first photographs. It was working ok but today it is killing any .dng files and .pefs that I try to work with.

The images show up in the thumbnails, and load up into the display window, but as soon as I use any of the tools, like click the set contrast checkbox to change from the camera setting - the image goes completely black. If I save the black file it saves as a black jpg or tiff. The thumbnail also goes black. If I view the image outside of the PDCU software the image is still ok - I can open it in Irfanview, and I can see the thumbnails in Windows Explorer. Any advice? I am on Windows XP, the software is Ver 4.0.0.7.

Grayboy

Link Posted 03/08/2010 - 16:09
Ok a bit of fresh information - this only seems to be happening with the images I took today. Last night I updated the K7 firmware to ver1.10. That seems to be too much of a coincidence.

Grayboy

Link Posted 03/08/2010 - 16:40
Got it sorted - the PDCU4 software needed an update as well to ver2.07. All is good.

Algernon

Link Posted 03/08/2010 - 18:46
That sounds very strange. They must have changed the format of the .PEF file?..... which is going to cause problems with other programs that read the original .PEF format file. Unless it's a secret part of the file that only Pentax know about and use?
Half Man... Half Pentax ... Half Cucumber

Pentax K-1 + K-5 and some other stuff

Algi

BigJacko

Link Posted 03/08/2010 - 22:20
Grayboy wrote:
Got it sorted - the PDCU4 software needed an update as well to ver2.07. All is good.

I'm confused... I have a K-x, which uses the same software as your K-7 - Pentax Digital Camera Utility 4, as you rightly said.

However, the latest version is not 2.07... it's version 4.21

http://www.pentax.jp/english/support/download_digital.html#soft

Daft question, maybe, but are you sure you're grabbing the right thing?
Neil
≡≡≡≡
Pentax K-x Pentax DA L 18-55mm f3.5-5.6 AL Pentax DA L 55-300mm f4-5.8 ED Pentax A 50mm f2.0 Pentax AF360FGZ flash Rikenon P 50mm f1.7 Vivitar CF 28mm f2.8 (K02 Komine) Tokina 80-200mm f4 Vivitar MC 2x22 Tele Converter

"Rules are for the obedience of fools and the guidance of wise men" - Douglas 'Tin-Legs' Bader

Grayboy

Link Posted 22/08/2010 - 10:33
just saw this - you're right Big Jacko, I meant ver 4.21 - no idea now where I got ver2.07 - brainphart probably

TonyCr

Link Posted 09/01/2012 - 17:02
This is a much later entry on the Digital Camera utility 4. Knowing it required a high spec (at least 2ghzt dual core) I was not surprised mine kept crashing. The problem is that with a quad core and 4Mbts RAM it is still doing it. Any suggestions? (Yes mine is the latest version (now 4.33) and the K7 I use has the latest firmware.
On the prog itself I prefer it for basic work to Photoplus. The white balance and exposure settings are good. It functions clumsily. I wish it had some instructions. Could the mag do some? (What do all the functions do?)

davidstorm

Link Posted 10/01/2012 - 00:22
Tony, I don't think the issues you are having are anything to do with the processing power / RAM needed to run this software. I have it installed on 4 PC's, two of which are low powered laptops with slow Celeron processors and low powered integrated graphics, the other two are desktops, one is a Pentium D 3GHz, the other an old Pentium 4. None of them has as much RAM as your machine. 3 run Windows XP, 1 runs Vista. The software runs fast and with no crashing issues on all 4 PC's. If I were you I would try giving your PC a good clear out and run a registry cleaner. If all else fails reformat your PC and re-install from scratch. Once you get it stable I'm sure you will soon learn how to use it and what all the tools do.

Regards
David
Flickr

Nicola's Apartments, Kassiopi, Corfu

Some cameras, some lenses, some bits 'n' bobs

TonyCr

Link Posted 10/01/2012 - 16:49
David, The PC is new so I don't think the problem lies in a clogged up registry. The purpose of my post was to see if any others had this problem. I could imagine your suggestions would fit my old machine. I am using it with DNG files - so they are large.

davidstorm

Link Posted 10/01/2012 - 20:58
TonyCr wrote:
David, The PC is new so I don't think the problem lies in a clogged up registry. The purpose of my post was to see if any others had this problem. I could imagine your suggestions would fit my old machine. I am using it with DNG files - so they are large.

Hi again Tony - is it possible there's an issue with Windows 7 (assuming the PC is running this operating system)? I also use only RAW DNG files that are large in size and as mentioned above I don't have any problems with the silkypix software on any PC I've tried it on, even the most lowly of laptops. When you say the PC is 'new' how new do you mean? This still doesn't rule out a registry or installation issue - you may have a corrupted DLL or something else amiss even on a brand new PC. I'm sure others can help and comment here, but I don't think the software is inherently unstable.

Regards
David
Flickr

Nicola's Apartments, Kassiopi, Corfu

Some cameras, some lenses, some bits 'n' bobs

wvbarnes

Link Posted 10/01/2012 - 21:48
Add a Comment
You must be registered or logged-in to comment.