Visit MPB Visit MPB Visit MPB

KS-2 Problem with back screen


psburnley

Link Posted 21/07/2017 - 18:08
Hi All

My well used but never abused KS-2 has lost any power to its back screen. Camera appears to be functioning as normal but nothing on the screen. I have twisted and turned the screen, reset info and menu, switched on and off (works for computers) and used a fully charged genuine battery. No joy at all. Has anyone else come across this problem?

The camera is out of warranty and Johnsons quote 178 + VAT for a standard repair.

It would appear to me a consequence of one of the great features of this camera, its flippy twisty screen and I have lost electrical contact somewhere.

Any experience of this? Any advice?

Peter

JAK

Link Posted 22/07/2017 - 23:06
You haven't by chance accidentally pressed the info button in such a way to turn the screen off have you? Though with that it should still show captured images, so if it doesn't do that either perhaps a wire has broken of come adrift as you say. If you haven't tried it, see if you can playback images though I get the feeling you have tried that. There are alternatives to Johnsons, but if you sign up here as a plus member you do get a discount. However I suspect you could pick a a nearly new or ex demo camera for around the same price as the repair quote.
John K

richandfleur

Link Posted 23/07/2017 - 22:20
JAK wrote:
you could pick a a nearly new or ex demo camera for around the same price as the repair quote.

That's so often the case with electronics these days.

I hope you find a magic button to press to revive the screen Peter.


Add a Comment
You must be registered or logged-in to comment.