Debug Mode K7


malcombe

Link Posted 16/09/2014 - 10:55
Whilst there has been a lot of discussion on this subject, I am confused.
I have a K7 and would like to remove the Debug Mode that is exhibited in the monitor.
I have Version 1.13 firmware update.
Can anyone assist?
Regards
Malcombe

GlynM

Link Posted 16/09/2014 - 15:49
Not tried by me but the 3rd-party PK-Thether, tethering and remote control software for Pentax DSLRs, has buttons to turn debug mode on and off.

Details can be found here.

As always there is some risk involved but it might be worth investigation.

Glyn

MattMatic

Link Posted 16/09/2014 - 16:33
Also, check whether you have the debug command file on your SD card
Think it's "MODSET.474" (see this page - you should be able to disable it with a plain text file, MODSET.474 with contents: "[DEBUG_MODE DIS]" )

(You could try formatting the card in-camera)
Matt
http://www.mattmatic.co.uk
(For gallery, tips and links)
Last Edited by MattMatic on 16/09/2014 - 16:34

GlynM

Link Posted 16/09/2014 - 16:42
I have just tried PK-Tether V0.7.0 on my K-7 and I was able to turn debug mode on & off.

My K-7 is firmware V1.13 and I ran PK-Tether from a Windows8.1 desktop.

I also had to turn off the camera Top LCD illumination, config menu screen 5 "29. LCD Panel Illumination" otherwise the top LCD was flashing which appears to be a known bug with PK-Tether.

The camera must have a memory card present.

This is what I tried:

Run PK-Tether.
Connect the K-7 to the PC using the USB cable.
Turn The camera on.
Under the the Debug mode menu bar entry select Camera debug mode on or off.
Close PK-Tether.
Turn the camera off.
Unplug the USB cable
Turn the camera back on again & check the LCD at start-up to see if it is in Debug mode or not.

And here is a screen dump:




I hope this helps,

Glyn
Last Edited by GlynM on 16/09/2014 - 16:58

wvbarnes

Link Posted 16/09/2014 - 18:39
Hi,

the same thing happened with my K5 when i had a play this week with PK tether. Just find the extra menu on your camera and you can turn it off.

Fun little program I think. Why don't Ricoh have an official version bundled with their cameras? Old question I know.

malcombe

Link Posted 16/09/2014 - 22:28
Thank you to all of you.
Glyn, I followed the advice in your 2nd comment and it seems to have turned off the 'Debug Mode'
Regards
Malcombe

GlynM

Link Posted 17/09/2014 - 09:20
malcombe wrote:
Thank you to all of you.
Glyn, I followed the advice in your 2nd comment and it seems to have turned off the 'Debug Mode'
Regards
Malcombe

Fantastic. Good to know that it worked.

Glyn
Add a Comment
You must be registered or logged-in to comment.