DA* 300mm AF not working


mattie

Link Posted 30/12/2021 - 21:37
Hi all

After a good few months of penny pinching I saved up enough to land a DA* 300MM at a really good price, thought it was too good to be true as the AF wont work on my K3. It simply does nothing, although switching between AF and MF on the lens mount registers on the body.

I'm currently giving the camera battery a full charge so I can flash the firmware (Current 1.1, latest 1.43) but nothing in the firmware literature to say there's noted issues with/fixes for 300mm so I'm not expecting the issue to be resolved through firmware.

The lens has in now way been abused, it's pretty much mint and boxed - although for some reason the tripod mount clamp is clearly an incorrect part which I've informed the shop about. No idea of vintage I'm afraid.

I've only got my K3 available as a Pentax body so can't try on other cameras but my 8-16 (my only other lens with SDM-type focus) works perfectly so it's not likely to be a problem with the body.

Any ideas for things to try? I've heard about manually focusing in and out but there's been no response from the AF at any point. I've heard stories about SDM issues but though these were for the most part resolved.

I'll call shop tomorrow, but any ideas on what to try beforehand appreciated.

Lubbyman

Link Posted 30/12/2021 - 21:49
Clean the contacts on the lens?

Steve

mattie

Link Posted 30/12/2021 - 21:52
Lubbyman wrote:
Clean the contacts on the lens?

Steve

I wondered about this too, so had a look and they're spotless. I gave them a quick wipe just in case but no difference.

JohnX

Link Posted 31/12/2021 - 09:07
Try rotating the focus ring back and forth a few times quite fast. The lens might have been unused for a time and got a bit sticky.

barkin

Link Posted 31/12/2021 - 13:24
Personally, I wouldn't do anything with it, bar send it back to the shop...

Pwynnej

Link Posted 31/12/2021 - 13:41
If you don't have an older Pentax camera body (ie pre-K DSLR) you might struggle..... On an older SLR the AF should work via the screw drive.

So, I would get the smallest screw driver you have and try to turn the focus drive on the bayonet and twiddle it... it might be stiff but turning it should slowly loosen it.

My DA*300 did go lethargic due to limited use but I was able to get it working normally again, with no further instances of lethargy.
Z-1p, K-1, P50
F50 1.7. FAs 24, 35, 50 1.4, 85, 135. DFA15-30, DFA24-70, D-FA*70-200. D-FA 100. The SMC-FA Limited Trinity.
Metz 45 CL-4, AF500FTZ. AF540FGZ.
Some Mamiya and some Nikon

Mike-P

Link Posted 31/12/2021 - 13:43
barkin wrote:
Personally, I wouldn't do anything with it, bar send it back to the shop...

This, presumably you got some sort of warranty with it so ask them to repair rather than refund.
. My Flickr

cbrog

Link Posted 31/12/2021 - 17:28
Otherwise convert it to screw drive - it's easy and works perfectly well and has no disadvantages over SDM unless a very slight noise is bothersome...I have converted my 16-50, 50-135 and 300. I wish it was possible to convert my 60-250 as well - it's getting a bit slow now.

mattie

Link Posted 31/12/2021 - 19:45
Tried the manual focus, no luck, also tried the screw drive - it certainly winds the focus in and out as I can see the focus dial move (amazed how low-geared it is!) but still no response from the AF.

Thanks for ideas in any case - I'll try again over weekend and if no joy I'll call shop next week. If the lens was one I'd had for a while and the AF died I would convert to screw drive, but it's been advertised as almost new so I'd prefer to return if it's not working.

Pwynnej

Link Posted 06/01/2022 - 10:23
Where are you Matt?, perhaps a nearby PUser can check the lens on their K-body.

You also say you've tried the AF/MF switch on the camera body, have you checked the switch on the lens?
Z-1p, K-1, P50
F50 1.7. FAs 24, 35, 50 1.4, 85, 135. DFA15-30, DFA24-70, D-FA*70-200. D-FA 100. The SMC-FA Limited Trinity.
Metz 45 CL-4, AF500FTZ. AF540FGZ.
Some Mamiya and some Nikon

mattie

Link Posted 11/01/2022 - 14:58
Good thinking, would have been nice to meet some forum members- I'm in Edinburgh and saw some brave soul on a windswept day at North Berwick with a 645, so presumably I'm not alone!

I've sent the lens back for investigation, as it's probably a good idea to get it properly checked over. It might be a while and they might see it as uneconomical (I'd hope not, given price of lens) but I've let them know I'd be happy to hold on in case it can be resolved.

Pwynnej

Link Posted 12/01/2022 - 09:36
Other end of the A1 then....let's hope the dealer resolves the issue.
Z-1p, K-1, P50
F50 1.7. FAs 24, 35, 50 1.4, 85, 135. DFA15-30, DFA24-70, D-FA*70-200. D-FA 100. The SMC-FA Limited Trinity.
Metz 45 CL-4, AF500FTZ. AF540FGZ.
Some Mamiya and some Nikon
Add a Comment
You must be registered or logged-in to comment.