K5 default values


thegreenman

Link Posted 16/08/2012 - 14:35
A question for K5 owners

What were the first changes you made to the factory default settings when you bought the K5.

just curious as I have just acquired one and am about to start fiddling.

regards

ChrisA

Link Posted 16/08/2012 - 14:41
- Turned off the beeps
- Turned off the top LCD light
- Turned down the back LCD brightness
- Switched "Use aperture ring" to "permitted" in the custom settings

Can't remember anything else
.
Pentax K-3, DA18-135, DA35 F2.4, DA17-70, DA55-300, FA28-200, A50 F1.7, A100 F4 Macro, A400 F5.6, Sigma 10-20 EXDC, 50-500 F4.5-6.3 APO DG OS Samsung flash SEF-54PZF(x2)
.

johnriley

Link Posted 16/08/2012 - 14:46
Centre point only for focus.
Centre-weighted metering.
Natural image style.
Premium JPEG quality.
Lock exposure to focus point.
Best regards, John

thegreenman

Link Posted 16/08/2012 - 14:48
Thanks Chris

I have done the beeps and allowed the use of the aperture ring. I can't think why this is not permitted by default, or even why there is a setting for it. Why would you want to disable the use of the aperture ring?

ChrisA

Link Posted 16/08/2012 - 15:21
thegreenman wrote:
Why would you want to disable the use of the aperture ring?

Because unless you know exactly how to do the metering when you use it, your exposures will be all up the swanee.

Better to default to not let the shutter fire in non-A modes IMO - then people that have a reason for using the aperture ring will go looking for it, and then discover stop-down metering.
.
Pentax K-3, DA18-135, DA35 F2.4, DA17-70, DA55-300, FA28-200, A50 F1.7, A100 F4 Macro, A400 F5.6, Sigma 10-20 EXDC, 50-500 F4.5-6.3 APO DG OS Samsung flash SEF-54PZF(x2)
.

ChrisR

Link Posted 16/08/2012 - 16:32
K5, now twelve months old, still on factory settings, not found the need to change anything.

Also no firmware updates.

Take care.
Chris R.

I. El. (Eng). (Rtd).

wvbarnes

Link Posted 16/08/2012 - 17:04
As well as the obvious turning off of preview screen, LCD screen light, status screen,silly bleeps, four star low compression jpeg (odd its not the default) etc

I've set up some User mode settings (you can do up to five)for fast action, landscape, night photography etc. for quick change.

I use TAV mode mostly and change to spot focus and spot AF when using telephoto.
Add a Comment
You must be registered or logged-in to comment.