Pentax Firmware Updates For K-3, K-S1 And K-S2

Pentax has released firmware updates for its K-3, K-S1 and K-S2 DSLR cameras.

15/04/2015 - 14:07

K3 18135 Front2

Pentax has announced firmware updates for 3 of its DSLR cameras; the K-3, K-S1 and K-S2. Details of the updates for each camera are listed below:

Pentax K-3 firmware version 1.20

  • Optimized performance of HD PENTAX-DA 18-50mm f/4-5.6 DC WR RE, HD PENTAX-D FA 150-450mm f/4.5-5.6ED DC AW and HD PENTAX-D FA*70-200mm f/2.8 ED DC AW.
  • Corresponded to AF button and preset button function for HD PENTAX-D FA 150-450mm f/4.5-5.6ED DC AW.
  • Improved stability for general performance.

*Contents of [Version 1.11] and earlier version will be also updated.

 

Pentax K-S2 firmware version 1.01

  • Optimized performance of HD PENTAX-D FA 150-450mm f/4.5-5.6ED DC AW and HD PENTAX-D FA* 70-200mm f/2.8ED DC AW.
  • Improved stability for general performance.

 

Pentax K-S1 firmware version 1.10

  • Optimized performance of HD PENTAX-DA 18-50mm f/4-5.6 DC WR RE, HD PENTAX-D FA 150-450mm f/4.5-5.6ED DC AW and HD PENTAX-D FA* 70-200mm f/2.8ED DC AW.
  • Corresponded to AF button and preset button function for HD PENTAX-D FA 150-450mm f/4.5-5.6ED DC AW.
  • Improved stability for general performance.

To download the updates click on the links to the relevant camera above. 


Related Photos
No related photos found. Check out the Pentax User Gallery.

mille19

Link Posted 15/04/2015 - 21:48
There's a bug in this firmware for the K3, confirmed by many who have updated.
The rear LCD turns on as soon as you touch the shutter release button, the LCD just lightens slightly (nothing displayed) but it must be using power and is a bit distracting when you hold the camera to your eye and the LCD turns on.
Last Edited by mille19 on 15/04/2015 - 21:48

mille19

Link Posted 16/04/2015 - 09:34
A bit of an update.
It's sounds like the bug is camera settings dependant, if you have your camera set so the display is on the 1.20 firmware seems to work OK.

I always have the display turned off to conserve the battery, if you have your camera settings to have the display off there is a bug in the 1.20 firmware.

gwb67

Link Posted 17/04/2015 - 18:21
I've done updates before on my K-3 without a problem but this one doesn't seem to want to install.
I get as far as "Turn the camera power on while pressing the MENU button" but it won't progress to the next step but just gives me the usual display.
Could it be that I'm on version 1.10? I seem to have missed 1.11.

johnriley

Link Posted 18/04/2015 - 09:45
That won't matter gwb67 - any update includes all previous updates. The BIN file needs to be on the SD card at the top level, not within a folder. Is that the case?
Best regards, John

gwb67

Link Posted 18/04/2015 - 11:30
Thanks for the reply. Yes it is at that stage.
I'll keep trying but am obviously doing something wrong.
It says press MENU while switching on but no response from mine. Am using a formatted card in slot 1 and full battery 😕

Strutton

Link Posted 18/04/2015 - 11:36
gwb67 wrote:
I've done updates before on my K-3 without a problem but this one doesn't seem to want to install.
I get as far as "Turn the camera power on while pressing the MENU button" but it won't progress to the next step but just gives me the usual display.
Could it be that I'm on version 1.10? I seem to have missed 1.11.

Strutton

Link Posted 18/04/2015 - 11:37
There are two memory slots. Try mounting the SDHC in the other slot.

gwb67

Link Posted 18/04/2015 - 11:42
Yes ok, but it does say use number 1.

gwb67

Link Posted 18/04/2015 - 12:59
Finally done it after 4 attempts. Never had this issue before but at least it's on!

tyronet2000

Link Posted 07/05/2015 - 17:21
gwb67 wrote:
Finally done it after 4 attempts. Never had this issue before but at least it's on!

Must have been heart stopping moments
Regards
Stan

PPG
Add a Comment
You must be registered or logged-in to comment.