SMC FA 100/2.8 Macro focusing problem


amplified

Link Posted 30/04/2012 - 01:08
Hi there,
i have a problem with my focusing ring on my recently acquired FA 100.
Firstly, it refused to focus to infinity, now the focusing ring is loose and doesn't even rotate, just a noise.
I think the focusing gear mechanism is out of alignment. Is there any service manual on the internet or somebody who has opened this lens can share thoughts.
And how much do you think lens repair would cost, though i am sure there is nothing broken, just the gears are off. I had the same problem with my sigma, but they fixed it under warranty. And do you know somewhere in Southampton or Portsmouth i can go to fix it.
http://bhristov.com
K-3 with FA 100/2.8 Macro, DA* 300/4 SDM, Sigma 150-500/5-6.3 APO HSM, Tamron 17-50/2.8 Di II, Sigma 17-70/2.8-4.5, DA 50/1.8, M 50/1.7 and Cobra 2X TC

johnriley

Link Posted 30/04/2012 - 08:46
Get in touch with Asahi Photo or Harrow Technical. They both cover older Pentax repairs.

I doubt that the job is a DIY one and I wouldn't chance ruining an expensive and desireable lens.
Best regards, John

Mannesty

Link Posted 30/04/2012 - 16:26
+1 from me. You risk destroying a 300 - 400 lens, that may not be easily replaced, by attempting what might be a simple and inexpensive repair for a professional repairer.

BTW, the fact that it wouldn't focus to infinity is no real problem for a macro lens, which is almost never used at infinity anyway.
Peter E Smith

My flickr Photostream
Last Edited by Mannesty on 30/04/2012 - 16:27

amplified

Link Posted 22/05/2012 - 03:31
Fixed it... all ok.
Young, dumb and brave, but everything is ok when it ends ok, right?
http://bhristov.com
K-3 with FA 100/2.8 Macro, DA* 300/4 SDM, Sigma 150-500/5-6.3 APO HSM, Tamron 17-50/2.8 Di II, Sigma 17-70/2.8-4.5, DA 50/1.8, M 50/1.7 and Cobra 2X TC

Mannesty

Link Posted 22/05/2012 - 06:59
Well done, you're a lot braver than I am.
Peter E Smith

My flickr Photostream

greynolds999

Link Posted 22/05/2012 - 16:26
Was it the tried and tested hitting it with a hammer and shouting "work you stupid ********"!
My Photobucket

Mike-P

Link Posted 22/05/2012 - 17:16
greynolds999 wrote:
Was it the tried and tested hitting it with a hammer and shouting "work you stupid ********"!

Ah, that's where I go wrong .. didn't realise you had to shout at the same time.
. My Flickr

amplified

Link Posted 23/05/2012 - 01:33
One of the screws was lost and the others was loose. Little tightening and it is all right now.
Got some aperture misalignment... +1.0EV error when stopping down after F2.8. After some 'scientific tests' i managed to get it to no error at all - works excellent at all apertures.
Then again... another problem occurred... i messed up the ribbon cable for the focus limiter-the result is no limiter now. Just Af from infinity to 1:1. Doesn't bother me at all.
When I get back home to Bulgaria where I have the right tools for the complete repair i will fix the ribbon cable and the lens will be back at excellent state.
Better no limiter than no focus at all.
It just behaves as DA/DFA.
http://bhristov.com
K-3 with FA 100/2.8 Macro, DA* 300/4 SDM, Sigma 150-500/5-6.3 APO HSM, Tamron 17-50/2.8 Di II, Sigma 17-70/2.8-4.5, DA 50/1.8, M 50/1.7 and Cobra 2X TC
Add a Comment
You must be registered or logged-in to comment.