smc da 50-135 f2.8 autofocus fault


Dizzifox

Link Posted 03/07/2015 - 14:06
HI All
I have a Pentax K5 and bought a used Pentax smc 50-135 f2.8 lens about a year ago. It worked perfectly until recently but now it wont autofocus at all ( I don't mean it struggles I mean it wont even try)
The strange thing is it works perfectly on my old camera (k100d) and my other lenses work fine on the K5.
Any advise would be greatly appreciated.
D
Last Edited by Dizzifox on 03/07/2015 - 14:10

Mike-P

Link Posted 03/07/2015 - 14:32
The SDM focus motor had probably given up, it's a fairly common problem with older copies of the 50-135mm and 16-50mm. It will work fine on your K100D as that uses 100% screw drive whereas the K-5 will use the SDM.

Repair cost is approximately 180-200.
. My Flickr

Dizzifox

Link Posted 03/07/2015 - 15:27
Mike-P wrote:
The SDM focus motor had probably given up, it's a fairly common problem with older copies of the 50-135mm and 16-50mm. It will work fine on your K100D as that uses 100% screw drive whereas the K-5 will use the SDM.

Repair cost is approximately 180-200.

Thanks For your help Mike. Will look into getting it repaired

percy

Link Posted 03/07/2015 - 21:44
Why not just convert it to screw drive only. I paid for a repair on one once, and then regretted spending the money and wished I'd just converted it myself. It's a great lens, but that SDM motor does seem to be a weakness! A little bit of googling will probably send you to pentaxforums.com and you'll find the instructions there
Add a Comment
You must be registered or logged-in to comment.