Sensor Clean on K3ii


redbusa99

Link Posted 09/09/2019 - 20:09
has anyone had a problm after a wet clean?
K3 II and the odd lens or 2

Flickr

JAK

Link Posted 09/09/2019 - 21:52
I've pondering whether to try one. Have you had a problem?
John K

Nigelk

Link Posted 09/09/2019 - 22:22
I recently had my first wet clean on my K-S2 performed by Jessops. They gave it a couple of goes as I wasn't totally happy after the first one. Nice to have a clean sensor back and no problems to report.
I'm not brave enough to do my own clean.

redbusa99

Link Posted 10/09/2019 - 13:35
no, but it seems the manual says to use the Pentax "sticky sweet on a stick thing" and not wet clean. just wodered why not a wet clean or if anyone did have a problem after one. it was/is a different sensor to K5 series after all but dfferent enough to need a specialised cleaning method?
K3 II and the odd lens or 2

Flickr
Last Edited by redbusa99 on 10/09/2019 - 13:37

HarisF1

Link Posted 10/09/2019 - 13:45
I cleaned my K-3 a few years ago. A wet clean worked perfectly. The only issue is that the dust spots returned very soon after so I just live with them now.

The kit I used came from Amaz0n - APS-C swabs and Eclipse cleaning fluid which I think is just pure methanol.

davidwozhere

Link Posted 11/09/2019 - 01:44
I have blasted the sensors on both my K5 and K3ii with a rocket blower (very carefully!). It did the job without any problems.
Both the *istDS and the K5 are incurably addicted to old glass

My page on Photocrowd - link
Add a Comment
You must be registered or logged-in to comment.