Pentax woes, tell us about yours.


DaveN

Link Posted 11/11/2011 - 10:21
I am no expert, but I think the K5 and SDM lenses have a higher fault rate than equivalent camera/lenses from the big two.

I still love my kit though and I would not change it I anything outthere.
Discovering the joys of photography with Pentax

pianoman

Link Posted 11/11/2011 - 12:52
First K5 sensor stain.. current K5 sent back for repair for jamming shutter 5 weeks ago still no sign of its return retailer awaiting part from Japan
This is the second time this has been sent back and in total to date lost 8 weeks
I love the K5 just wish I could get a working one
My K-m and D200 and K7 had no problems with any of these
All the best

David

DrOrloff

Link Posted 11/11/2011 - 15:40
I lost four months with my K20 repairs so you have my complete sympathy, hope it gets resolved soon.
You can see some of my photos here if you are so inclined

Maeluk

Link Posted 27/05/2012 - 07:47
I bought my K5 two weeks ago. I love it but it has locked up twice this weekend forcing me to remove the battery grip and take the battery out of the camera to get it to work again. Surely, a camera that locks up so often has a problem that needs sorting out ?

Mike-P

Link Posted 27/05/2012 - 14:10
Are you using a copy grip or original ... same with the batteries?
. My Flickr

gartmore

Link Posted 27/05/2012 - 15:41
Good point Mike. Take off the grip and use the Pentax battery in the body and see if it happens again.
Ken
“We must avoid however, snapping away, shooting quickly and without thought, overloading ourselves with unnecessary images that clutter our memory and diminish the clarity of the whole.” - Henri Cartier-Bresson -

Maeluk

Link Posted 27/05/2012 - 20:29
I have a pentax original grip but I didn't get a pentax battery ..will this make a difference ? Although I had the grip attached it wasn't switched on. I have tried the Pentax without the grip and took two hundred photos today with no problem.
Last Edited by Maeluk on 27/05/2012 - 20:32

Offertonhatter

Link Posted 27/05/2012 - 21:33
My K-5 is an early one with staining. But do you know what? In real use it does not have an effect at all.
Two reasons I have not sent it back
1 - I use it all the time, so no time to to send it back
2 - It does not have an effect.

However I does succome to dust more than my K20D. But I have PS to sort that out.....LOL

The only other Pentax problem I have, is my 50-135 is a bit reluctant to AF if not used for a while (typical SDM), but I get around it - ie put it on the camera and coerce it to work, then it is fine.

Apart from those, NIL NADA etc. I Love the Pentax System.
Some Cameras

Mannesty

Link Posted 28/05/2012 - 07:12
I've started a separate topic about my locking up problem here so I'll not repeat it here.

Suffice it to say that the issue I had was the first time I've had any significannt problem with the camera, and I was using a third party battery at the time.
Peter E Smith

My flickr Photostream
Last Edited by Mannesty on 28/05/2012 - 07:15

beakynet

Link Posted 29/05/2012 - 16:33
Offertonhatter wrote:

The only other Pentax problem I have, is my 50-135 is a bit reluctant to AF if not used for a while (typical SDM), but I get around it - ie put it on the camera and coerce it to work, then it is fine.

I had the same issue with my 50-135, it was a slow downward spiral to less reliable focus, finally it went to Harrow Technical - £100 spend I haven't regretted.

Now I think the 16-50 might be starting to show the same issue!

I did have a problem with the pop up flash spring on my 5MZn years ago - that was fixed.

appart from the front/back focussing issues with lense just 2 failures in 27 years of using Pentax!
Bodies: K5IIs, K7, MZ5n, LX, MV
Lenses: DA*16-50, DA18-55WR, DA18-135, DAL35, M50 F2, A50 f1.4, FA50 f1.4, DA*50-135, DA55-300, Tamron 70-300, DFA 100 WR Macro, M135 f3.5, Sigma 120-400 APO DG HSM, Tokina 500 f8.0
Flash: Metz 58, Metz 48
Accessories: BG4, Pentax right angle finder, Pentax mirror adaptor lens, O-ME53 Viewfinder Loupe
Auto 110 System: Auto 110, Winder, 18mm, 24mm, 50mm, 70mm, 20-40mm, AF100P, 1.7x telecon
Last Edited by beakynet on 29/05/2012 - 16:34

Smeggypants

Link Posted 29/05/2012 - 20:37
Maeluk wrote:
I have a pentax original grip but I didn't get a pentax battery ..will this make a difference ? Although I had the grip attached it wasn't switched on. I have tried the Pentax without the grip and took two hundred photos today with no problem.

Shouldn't do. all my 3rd party batteries ahve performed just as well as the pentax supplied ones
[i]Bodies: 1x K-5IIs, 2x K-5, Sony TX-5, Nokia 808
Lenses: Pentax DA 10-17mm ED(IF) Fish Eye, Pentax DA 14mm f/2.8, Sigma 17-70mm f/2.8, Pentax-A 28mm f/2.8, Sigma 30mm F1.4 EX DC, Pentax-A 50mm f/1.2, Pentax-A 50mm f/1.4, Pentax-FA 50mm f/1.4, Pentax-A 50mm f/1.7, Pentax DA* 50-135mm f/2.8, Sigma 135-400mm APO DG, and more ..
Flash: AF-540FGZ, Vivitar 283

woodworm

Link Posted 29/05/2012 - 21:14
After reading some of these I realise I've been really lucky

If I was without a camera for 4 months I would have sold up and moved elsewhere regardless of how much I liked my GX20; DrOrloff has a lot more patience than me!

My only issue is that occasionally my 100mm DFA macro doesn't focus manually, I mean I turn the ring but the lense doesn't move. It always works in auto focus. Doesn't happen that often ...

davidstorm

Link Posted 29/05/2012 - 22:31
I have a K-5, a K-x and a K-m and have had no issues at all with any of them, apart from the K-x needed a hacked autofocus adjustment of +230!!! Yes, it was that far out on autofocus, whereas the K-5 and K-m are absolutely spot-on.

K-5 level is accurate, no lock-ups, no staining, nothing wrong at all. The K-m is just a pleasure to use (except it's a bit slow) and has the most beautiful sensor (as long as you don't push the ISO) and apart from the focus adjustment, the K-x is sensational for the price.

Oh, and I have bought some fabulous lenses for very little money.

I love my Pentax gear and will not be changing to any other brand.

Regards
David
Flickr

Nicola's Apartments, Kassiopi, Corfu

Some cameras, some lenses, some bits 'n' bobs

Smeggypants

Link Posted 30/05/2012 - 00:09
My first K-5 had a faulty AF at low light which OS V1.03 didn't address. I had it replaced for another one, which 1.03 did address. MY second ( or rather 3rd ) K-5 also works fine. My previous two DSLRs, K10D and K20D also worked fine.
[i]Bodies: 1x K-5IIs, 2x K-5, Sony TX-5, Nokia 808
Lenses: Pentax DA 10-17mm ED(IF) Fish Eye, Pentax DA 14mm f/2.8, Sigma 17-70mm f/2.8, Pentax-A 28mm f/2.8, Sigma 30mm F1.4 EX DC, Pentax-A 50mm f/1.2, Pentax-A 50mm f/1.4, Pentax-FA 50mm f/1.4, Pentax-A 50mm f/1.7, Pentax DA* 50-135mm f/2.8, Sigma 135-400mm APO DG, and more ..
Flash: AF-540FGZ, Vivitar 283

Frogherder

Link Posted 30/05/2012 - 09:15
I have a K10D & K5 & both perform better than I do.

The only issue I can complain about is that occasionally the AF goes out to infinity & back before settling. This happens with the kit 18-55mm; Tamron 90/2.8; and Sigma 70-300/4-5.6 (the only AF lenses I have). This applies to both cameras and whilst irritating at the time dos not appear to be reproduceable and too sporadic to have them looked at (they could be away weeks an not do it)

regards
Bernard
Add a Comment
You must be registered or logged-in to comment.