New Pentax Firmware updates for 6 cameras


Daniel Bridge

Link Posted 04/02/2013 - 15:31
I would also point out, that I was as skeptical as I usually am when I heard people saying that AF was improved. Just had a look back through shots of my daughter, today's ones of her on the move are just so much better than I've ever had before.

Dan
K-3, a macro lens and a DA*300mm...

malvern_man

Link Posted 04/02/2013 - 20:45
Just updated my K5II and K5, no problems.
My Website

Smeggypants

Link Posted 04/02/2013 - 21:59
After hearing anecdotes of improved AF with V1.14, I caved in today and decided to update one of my K-5s to 1.14. The other I kept at V1.03

I've tested all my lenses extensively and I can report absolutely no difference whatsoever. Focusing speed was exactly the same on both cams.

There was also no change in any AF adjustments needed. The AF settings for V1.14 were exactly the same as for V1.03

I also rechecked my other K-5 AF settings on v1.03 and that didn't need any further adjustment either. The AF tweaks I applied nearly two years ago still applied. I wouldn't have been surprised at a bit of drift.
[i]Bodies: 1x K-5IIs, 2x K-5, Sony TX-5, Nokia 808
Lenses: Pentax DA 10-17mm ED(IF) Fish Eye, Pentax DA 14mm f/2.8, Sigma 17-70mm f/2.8, Pentax-A 28mm f/2.8, Sigma 30mm F1.4 EX DC, Pentax-A 50mm f/1.2, Pentax-A 50mm f/1.4, Pentax-FA 50mm f/1.4, Pentax-A 50mm f/1.7, Pentax DA* 50-135mm f/2.8, Sigma 135-400mm APO DG, and more ..
Flash: AF-540FGZ, Vivitar 283

Daniel Bridge

Link Posted 04/02/2013 - 22:19
I wouldn't say focusing is any quicker, and I still have the same adjustments as before. But accuracy in low light especially is better, and it seems to follow moving subjects better. That is with limited and unscientific testing, which I know won't please you Smeggy.

My 'before-' and 'after-update' shots were literally sat in the same spot, same low light from shaded 60W equivalent low energy desk lamp, and the 'before' ones followed this sort of sequence:

Shoot, check, out of focus
Shoot, check, out of focus
Shoot, check, not bad
Shoot, check, out of focus
Shoot, check, out of focus

Whereas after the update it was:

Shoot, check, wow, bang on
Shoot, check, wow, another bang on
Shoot, check, er wow, bang on again
Shoot, check, oh, a bit off
Shoot, check, ah, bang on again

I can't think of any other reason for this, other than something in the firmware.

Dan
K-3, a macro lens and a DA*300mm...

Smeggypants

Link Posted 04/02/2013 - 23:31
Daniel Bridge wrote:
That is with limited and unscientific testing, which I know won't please you Smeggy.


It doesn't displease me and I've no reason to disbelieve your experience on updating. It's clear some are experiencing improevments an some aren't.

I Have to say though, I never had ...

Quote:

Shoot, check, out of focus
Shoot, check, out of focus
Shoot, check, not bad
Shoot, check, out of focus
Shoot, check, out of focus

before updating.

What version did you update from? ( forgive me if you already said )
[i]Bodies: 1x K-5IIs, 2x K-5, Sony TX-5, Nokia 808
Lenses: Pentax DA 10-17mm ED(IF) Fish Eye, Pentax DA 14mm f/2.8, Sigma 17-70mm f/2.8, Pentax-A 28mm f/2.8, Sigma 30mm F1.4 EX DC, Pentax-A 50mm f/1.2, Pentax-A 50mm f/1.4, Pentax-FA 50mm f/1.4, Pentax-A 50mm f/1.7, Pentax DA* 50-135mm f/2.8, Sigma 135-400mm APO DG, and more ..
Flash: AF-540FGZ, Vivitar 283

MarkTaylor

Link Posted 04/02/2013 - 23:43
malvern_man wrote:
Just updated my K5II and K5, no problems.

Ditto.
My Flickr Pentax K-5 K-5 II Sigma 8-16mm F/4.5-5.6 DC HSM Tamron SP AF 17-50mm F/2.8 XR Di II LD ASL SMC Pentax-DA* 50-135mm F/2.8 ED [IF] SDM SMC Pentax-DA 55-300mm F/4-5.8 ED SMC Pentax-DA 18-135mm F/3.5-5.6 ED AL [IF] WR Vivitar 100mm F/3.5 Macro AF Metz Mecablitz 58 AF-2

cabstar

Link Posted 05/02/2013 - 00:11
Have upgraded both ny mki and mkii from the previous firmware update and see no difference in af at all. Both bodies are set up exactly the same, tested in my lounge under 120 watts of household lighting. Mki still hunts under the table, mkii no problem as before. Above the table mk1 still hunts and eventually locks on, mkii locks straight on.

I can only assume some are updating from 1.0 which did have af issues and where fixes in version 1.02 I believe.
PPG Wedding photography Flickr
Concert photography

Currently on a Pentax hiatus until an FF Pentax is released

Smeggypants

Link Posted 05/02/2013 - 00:22
cabstar wrote:
Have upgraded both ny mki and mkii from the previous firmware update and see no difference in af at all. Both bodies are set up exactly the same, tested in my lounge under 120 watts of household lighting. Mki still hunts under the table, mkii no problem as before. Above the table mk1 still hunts and eventually locks on, mkii locks straight on.

I can only assume some are updating from 1.0 which did have af issues and where fixes in version 1.02 I believe.

This is what I as thinking. 1.03 was the AF fix update btw
[i]Bodies: 1x K-5IIs, 2x K-5, Sony TX-5, Nokia 808
Lenses: Pentax DA 10-17mm ED(IF) Fish Eye, Pentax DA 14mm f/2.8, Sigma 17-70mm f/2.8, Pentax-A 28mm f/2.8, Sigma 30mm F1.4 EX DC, Pentax-A 50mm f/1.2, Pentax-A 50mm f/1.4, Pentax-FA 50mm f/1.4, Pentax-A 50mm f/1.7, Pentax DA* 50-135mm f/2.8, Sigma 135-400mm APO DG, and more ..
Flash: AF-540FGZ, Vivitar 283

cabstar

Link Posted 05/02/2013 - 08:21
ah I knew it was one if the early versions...
PPG Wedding photography Flickr
Concert photography

Currently on a Pentax hiatus until an FF Pentax is released

annieogg

Link Posted 05/02/2013 - 08:38
After reading this post thought I would up grade. Wasn't worried about doing it as did when I got the camera. Don't know where I'm going wrong but each time I try all I get is the current firmware number coming up. Have tried reformating card tried differant cards but no joy :S at least nothing has changed on camera. Might have another go later.
All roads roam to Leeds
linklink

Pentax K-5 18-55mm Tamron 70-300mm
Pentax 35mm
a few filters Manfrotto tripod and monopod Silk tripod and a bumbling approach on how to use them

richandfleur

Link Posted 05/02/2013 - 09:06
K-30 update ok for most people?

annieogg

Link Posted 05/02/2013 - 10:00
Sorted now redownloaded and unpacked with winzip this time got it to work but now I take a shot and its displayed in B&w on PC they are colour tho
All roads roam to Leeds
linklink

Pentax K-5 18-55mm Tamron 70-300mm
Pentax 35mm
a few filters Manfrotto tripod and monopod Silk tripod and a bumbling approach on how to use them

annieogg

Link Posted 05/02/2013 - 10:06
LOL I must have altered settings in camera but all good now
All roads roam to Leeds
linklink

Pentax K-5 18-55mm Tamron 70-300mm
Pentax 35mm
a few filters Manfrotto tripod and monopod Silk tripod and a bumbling approach on how to use them

Daniel Bridge

Link Posted 05/02/2013 - 19:36
I was updating from version 1.13. Mine has never had great success focusing in dim artificial light. It does seem a lot better now, from my admittedly brief testing. I don't know why.

Dan
K-3, a macro lens and a DA*300mm...

cedricd

Link Posted 05/02/2013 - 19:57
I updated both my K5 and K30. Similarly as Dan I tried both in a dimly lit room, the K30 is much faster on the focus than the K5. When I updated to v 1.13 on the K5 there was a significant increase in AF speed but I don`t think the latest version has made much difference. Just need a bit of time to really give them both field trials. Who knows what else Pentax slipped in?
Enjoy life
Add a Comment
You must be registered or logged-in to comment.