K5 randomly releasing mirror upon half-way press of the shutter


Ohawa

Link Posted 10/05/2014 - 21:08
Hello, I have a strange problem with my K5. Sometimes when I turn the camera on it flips the mirror without any reason, sometimes several times. On the same occasion (or another time) when half-pressing the shutter release button it flips the mirror several times and only after that I can take an image. Several times is about 2-3-4 times. Firmware 1.15, will be upgraded to 1.16 but this does not seem to be the issue. All settings are normal (mostly the green ones or default ones), camera operated almost exclusively in Av mode, happens with different lenses (third party at least, will have to verify with Pentax ones). Before the camera worked properly. Shooting PEF with center AF and AF.S mostly.
Any idea what could this be? I can still take photos but it is quite annoying.
Thanks, Jiri

matwhittington

Link Posted 11/05/2014 - 10:02
I think it's definitely with making sure the firmware is up to date (you seem to be onto that). Other suggestion would be to take the battery out and leave it out fort an hour or so before replacing. Not sure if that will do anything but sometimes its helpful I think... sorry can't be more help.

Cheers
Mat W

My Flickr: link

Gamka

Link Posted 11/05/2014 - 10:11
Before you do the firmware update, reset the camera to "factory defaults" so any odd/strange setting will be cleared. Then do the upgrade.

Ohawa

Link Posted 11/05/2014 - 17:15
Yes genuine battery. Will do the reset and then upgrade. Hopefully I just activate some odd feature. Thanks for your help.

Dodge69

Link Posted 11/05/2014 - 17:42

bettyswolloks

Link Posted 11/05/2014 - 19:39
Had a similar sounding problem with my IIs the day before it went back for a different repair. It came back after they had reset the shutter, but never got to try it out due to the other repair not getting done, buts that's another story!

darkskies

Link Posted 11/05/2014 - 21:55
I've started having this problem with my K5, every now and again. I'm now glad I decided to get it 2nd hand from SRS!
This space deliberately left blank.

Ohawa

Link Posted 11/06/2014 - 07:57
Ok after several weeks I haven't observed anything new, battery (original) full or half empty, different SDHC cards, different (Pentax and third party) lenses. Sometimes it simply flips the mirror several times and only after that allows shooting or focusing. Latest firmware, I forgot to say, mostly default settings.
It is not the behaviour observed by some users with the mirror going mad. It is only a few flips, say 4 to 5.
The only thing I noticed is that when cleaning the mirror there is some whinning sound but it could have been there before as well.
Anyway, thanks for your comments.
I'll see whether Pentax can do something about it.

bettyswolloks

Link Posted 11/06/2014 - 07:59
I finally got my IIs back yesterday and its doing the exact same thing!

bettyswolloks

Link Posted 11/06/2014 - 08:03
Ohawa wrote:
Ok after several weeks I haven't observed anything new, battery (original) full or half empty, different SDHC cards, different (Pentax and third party) lenses. Sometimes it simply flips the mirror several times and only after that allows shooting or focusing. Latest firmware, I forgot to say, mostly default settings.
It is not the behaviour observed by some users with the mirror going mad. It is only a few flips, say 4 to 5.
The only thing I noticed is that when cleaning the mirror there is some whinning sound but it could have been there before as well.
Anyway, thanks for your comments.
I'll see whether Pentax can do something about it.

Does it do it EVERYTIME you turn it on?

Ohawa

Link Posted 11/06/2014 - 09:04
No, randomly. I have no idea whether it is related to outside temperature. Usually upon turning on the first time in the day there are no signs of problem but after several shots it starts.

Bugs

Link Posted 11/06/2014 - 12:27
Hi Ohawa,

I had this problem with my K5. I bought it in March 2011 and there was no problem till August 2011 while I was recording travel well away from home - as you know it is very annoying. It was under warranty and I sent it back to the dealer. The camera was replaced, so I suggest that you do likewise. Good luck!
Pentax K5, Sigma 18-200mm f3.5-6.3 DC lens. Manfrotto tripod & cable shutter release. Lightroom V5.

Ohawa

Link Posted 11/06/2014 - 12:30
I'd do it like you but unfortunately my camera is not under warranty anymore. Otherwise I would not bother you with these questions, of course.
I'll contact local Pentax dealer to see what can be done and especially for which price. But thanks anyway.

redbusa99

Link Posted 11/06/2014 - 13:59
you could try to fight for a replacement as it is an inherent fault by the looks of it no matter what people with Pentax tunnel vision may say.
odd lens or 2

Flickr

Ohawa

Link Posted 11/06/2014 - 14:03
Sure that's what I will try, replacement or repair for free or a modest sum. We'll see. I'll let you know the outcome.
Add a Comment
You must be registered or logged-in to comment.