K3 grip - battery not recognised


ilovesaabs

Link Posted 10/06/2018 - 16:07
Was off out today - Open Gardens in London so I went to Strawberry Hill in Twickenham...

LCD said batteries were flat - go into menu system and display tells me there is no battery in the tray. THinking the battery might be flat I placed a freshly charged battery in the grip - ZERO, nothing. Same battey in the camera - FULL CHARGE. Yet if I take a photo in portrait mode with charged battery in camera, the wheels and shutter button work...

Batteris are all OEM D-Li90.

Grip on the blink? anything else I should look for?

Ta
Peter
AKA Welshwizard/PWynneJ
Assorted Pentax/Nikon/Mamiya stuff

bforbes

Link Posted 10/06/2018 - 16:42
There is a small pin inside the grip just under the right hand spring that registers that a battery is in the tray. does that look to be ok?
Are all the pins that connect to the body moving freely?
Barrie
Too Old To Die Young
.
Pentax K1 K5-IIS K-01 K20D A50/2 A50/1.7 DA10-17 DA18-250 DA18-135 DA18-55 DA300 DA40 DA50-135 DA50-200 DA55-300 DA70 F35-70 DFA150-450 FA20-35 FA100 FA135 FA35 FA28 FA43 FA50 FA77 K55/1.8 M135/3.5 M200/4 M28/3.5 M28/2.8 M40/2.8 Q 01 02 MX-1 I-10 Sigma 15 24 105 180 8-16 10-20 17-35 17-50/2.8 24-70 400/5.6MF Tamron 70-200/2.8 17/3.5MF 24/2.5MF 28/2.5MF 90/2.5MF


http://www.pentaxphotogallery.com/artists/barrieforbes

ilovesaabs

Link Posted 10/06/2018 - 18:24
both sets of connections look fine Barrie... thanks
AKA Welshwizard/PWynneJ
Assorted Pentax/Nikon/Mamiya stuff
Add a Comment
You must be registered or logged-in to comment.