k3 and metz 64 af-1 not getting on


balsembi

Link Posted 17/06/2016 - 19:23
hi all
i have the k3 and the metz 64 af1. i am unable to fire the flash off camera, ive tried the aputure triggmaster and even a direct connection using a flash sync cord but nothing. it only works mounted on the k3 hotshoe.
i have 2 other yongnuo speedlites and they work fine with the cord and triggers.
surely a flash this advanced should work....so what am i doing wrong here?

all help welcome
thank you
Pentax K3 Pentax SMC-FA 50mm 1.4
Pentax Kr Pentax SMC D FA 100mm F2.8 Macro
SMC DAL 18-55mm Pentax SMC DA 18-270mm F3.5-6.3
SMC DAL 55-300mm Pentax DA 15mm HD F4ED AL
SMC Pentax-M 1:2.8 28mm
Last Edited by balsembi on 17/06/2016 - 19:24

McGregNi

Link Posted 18/06/2016 - 14:08
I think people would like to help, but I think you need to give more information on the exact settings you're using, on the camera, triggers and flash ... Pictures of the equipment set ready to go would help too.

You've bought a top range dedicated system flash, so it works wirelessly with the Pentax P-TTL system (you could use the pop-up flash as the control trigger) .... Have you tried that? It needs configuring first, so check the flash manual.

At the moment you're stuck not knowing if the problem is with the camera, flash, triggers or cord ....
My Guides to the Pentax Digital Camera Flash Lighting System : Download here from the PentaxForums Homepage Article .... link
Pentax K7 with BG-4 Grip / Samyang 14mm f2.8 ED AS IF UMC / DA18-55mm f3.5-5.6 AL WR / SMC A28mm f2.8 / D FA 28-105mm / SMC F35-70 f3.5-4.5 / SMC A50mm f1.7 / Tamron AF70-300mm f4-5.6 Di LD macro / SMC M75-150mm f4.0 / Tamron Adaptall (CT-135) 135mm f2.8 / Asahi Takumar-A 2X tele-converter / Pentax AF-540FGZ (I & II) Flashes / Cactus RF60/X Flashes & V6/V6II Transceiver

balsembi

Link Posted 19/06/2016 - 00:48
hi
yes, its definitely not the cord as it works with my other speedlites.
i have tried every setting but still no joy
McGregNi wrote:
I think people would like to help, but I think you need to give more information on the exact settings you're using, on the camera, triggers and flash ... Pictures of the equipment set ready to go would help too.

You've bought a top range dedicated system flash, so it works wirelessly with the Pentax P-TTL system (you could use the pop-up flash as the control trigger) .... Have you tried that? It needs configuring first, so check the flash manual.

At the moment you're stuck not knowing if the problem is with the camera, flash, triggers or cord ....


Pentax K3 Pentax SMC-FA 50mm 1.4
Pentax Kr Pentax SMC D FA 100mm F2.8 Macro
SMC DAL 18-55mm Pentax SMC DA 18-270mm F3.5-6.3
SMC DAL 55-300mm Pentax DA 15mm HD F4ED AL
SMC Pentax-M 1:2.8 28mm

MattMatic

Link Posted 19/06/2016 - 07:13
P-TTL mode won't be able to work off camera (unless you use a 5 pin cable). It's likely the flash is refusing to fire if it's only seeing just the plain old trigger pin (from your wireless slave widgets).

I'd suggest trying the Metz in "M" mode, 1/64 power and check that all works.
Matt
http://www.mattmatic.co.uk
(For gallery, tips and links)
Add a Comment
You must be registered or logged-in to comment.