K1 stuck on manual mode


alimid

Link Posted 19/12/2016 - 14:25
Hi my K1 is stuck on manual mode. Turning the mode dial makes no difference. I have tried a different battery, reset camera, tried different lenses. It is the latest firmware which was working okay. Any help will be gratefully accepted.

Alistair
Pentax K-1, K-3,K-5,

johnriley

Link Posted 19/12/2016 - 14:59
I would check the lens and lens mount contacts are all clean and free of dirt or grease. Use a soft dry cloth.

The only circumstance I can think of where turning the dial makes no difference is if a lens is fitted with no electronic contacts, or an A lens or later is fitted and the aperture ring is not set to A.
Best regards, John

Helpful

JAK

Link Posted 19/12/2016 - 15:06
Not saying it is, but it could be: K1-mode-dial-failure
So wouldn't be the first. Be interested to hear how you get on; at least its still under warranty if it comes to that.
John K

Helpful

McBrian

Link Posted 10/08/2018 - 10:38
Old thread I know but I've just been hit with this Mode Dial failure and I'm 4 months out of warranty

I spoke Johnsons Photopia who could not give me a definite cost, could be up to 199 but as its a major failure - and not the only one from the first production batch I may get it repaired under warranty.

I was't going to do it but I've also elected to do the upgrade while it's with JP.

Will keep the forum informed.
Cheers
Brian.
LBA is good for you, a Lens a day helps you work, rest and play.
Add a Comment
You must be registered or logged-in to comment.