it happened again, the cactus doesn't fir the metz anymore!


sebas77

Link Posted 15/04/2018 - 13:50
Oh no the dreadful terror happened again, after hours of testing it stopped working. I don't even know why, I think the last thing I did on the cactus was to set the HSS to off and maybe I manually set the flash from HSS to normal PTTL.

I tried everything, off/on everything, swapping transmitter receiver, factory reset. The communication happens (I can see the power in the cactus changing), but the flash just don't trigger. It does once if I turn it off an on. It works fine if I put it on the camera.

Some photo attached, as now I have the time to investigate properly, but I had to take a break because it literally makes me super angry.

it may be due to the multi brand firmware, if I can't make it shoot at all I will update the firmware again.


20180415_133327 by sebafoto, on Flickr


20180415_133332 by sebafoto, on Flickr

P.S.: battery on the flash is charged. The camera one says that it's dying, but the pentax cameras never really got it right, especially on the not pentax brand batteries. In this case the battery is actually full.
Last Edited by sebas77 on 15/04/2018 - 13:52

sebas77

Link Posted 15/04/2018 - 14:24
still investigating, since I have time now to do with serenity, I started to remove variables:

- switched everything to manual
- used manual flash (old cheap yognuo)
- initially it wasn't working either. I decided to clean the contacts, it now works
- mounted the metz, kept in manual works
- switch to the right profile, stop working again, but I get now this:

https://www.flickr.com/photos/sebaslab/41471511481/

waaat? (notice I am in M mode and not touch anything)
Last Edited by sebas77 on 15/04/2018 - 14:26

sebas77

Link Posted 15/04/2018 - 14:47
new progress, I set everything to flash metz 58 af2 explicitly, now it recycles but not fires...it's incredible how it was working 1h ago just fine!

https://www.flickr.com/photos/sebaslab/27600889698/in/album-72157665256698417/

I think the only thing left to do is to revert the firmware
Last Edited by sebas77 on 15/04/2018 - 14:56

sebas77

Link Posted 15/04/2018 - 15:14
Note if I set the cactus to profile Auto the receiver will not recognize the metz, I have to put it to profile pentax. Still doesn't fix it

Edit: OK reverting to the pentax firmware fixes everything, there must be a bug in the multi brand version. Damn it, obviously I have to sell the just bought cactus v6

BTW I have not intention to test it again but I strongly suspect that the low power setting triggered the bug. Still it's incredible that there was no way to fix it
Last Edited by sebas77 on 15/04/2018 - 15:34

pschlute

Link Posted 15/04/2018 - 16:51
The Cactus/Metz compatibility does seem to be a theme.
Peter



My Flickr page

sebas77

Link Posted 15/04/2018 - 16:55
and the sound track is me swearing in multiple languages. Anyway the XTTL firmware fixes it.

sebas77

Link Posted 16/04/2018 - 12:10
cactus confirmed the bug, it's indeed fixed in the Pentax XTTL firmware but not in the multi brand one, the will fix it with the next multi brand release
Add a Comment
You must be registered or logged-in to comment.